Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 1.9
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows XP, JDK 1.5
    • Number of attachments :
      0

      Description

      Situation: Sun's jaxrpc has a QName class but also put out a fix jar with an update to make that class compatible with JDK 1.5. In mule we missed out on the patch jar but since the .classpath generated by maven-eclipse-plugin-1.9 references the JRE_CONTAINER ahead of other jars, people who used JDK 1.5 for development missed this since a working QName was found when it really should not have been (correctly raising an error caused by the 'bad' class and the lack of the patch jar instead).
      Solution and proposed fix: move the JRE_CONTAINER to the end of the dependency list, after the j:forEach block that follows in the current version.
      IMHO the JRE_CONTAINER should always come last. This is unlikely to cause problems because you cannot accidentally override essential classes (e.g. java.lang), but it is essential when you do want to handle optional packages correctly (say a working QName or JMX).

        Activity

        Holger Hoffstätte added a comment -

        BTW I suspect generated files for other IDEs might have the same problem (IDEA?).

        Trygve Laugstøl added a comment -

        See MNG-1020 why this isn't the correct solution to a valid problem.

        Michael Osipov added a comment -

        Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


          People

          • Assignee:
            Unassigned
            Reporter:
            Holger Hoffstätte
          • Votes:
            0 Vote for this issue
            Watchers:
            3 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: