Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      4

      Description

      There is currently no way to make source and distributions for multiprojects. It would be great if the dist plugin supported this.

      1. dist-plugin.patch
        8 kB
        Alex Karasulu
      2. dist-plugin-2.patch
        8 kB
        Alex Karasulu
      3. dist-plugin3.patch
        10 kB
        Alex Karasulu
      4. distPlugin4.patch
        11 kB
        Phil Steitz

        Activity

        Alex Karasulu added a comment -

        This is a patch which adds the following goals:

        dist:multiproject
        --> calls the bin and src goals below)
        dist:multiproject-bin
        --> generates the binary distro with consolidated javadocs
        dist:multiproject-src
        --> generates the source distro

        Alex Karasulu added a comment -

        Ok this patch fixes some copy issues and puts things under the right top level directory

        Alex Karasulu added a comment -

        Added deployment goals for multiproject because other goals were overwriting the multiproject distros with a top level distro generation. The plugin now does pretty much everthing for multiprojects that it can for single projects.

        Phil Steitz added a comment -

        Attaching distPlugin3.patch that fixes combined javadoc classpath and externalizes list of files from top-level directories to include in src and bin distributions. Defaults match current behavior.

        I am starting to think that the combined javadoc bit really belongs in multiproject:site. I need it there in any case.

        Alex Karasulu added a comment -

        This issue is not really finished regardless of an initial commit of the dist multiproject code here:

        http://svn.apache.org/viewcvs.cgi?rev=151648&view=rev

        I will get to this as I figure out some things with phil regarding his patch #3 and email trails pertaining to this issue.

        Phil Steitz added a comment -

        Sorry, in the comment above, I meant patch #4 (the last one) not #3.

        Benoit Xhenseval added a comment -

        Shouldn't this be closed? Looks like the patch made it to 1.7.1 at least?

        Lukas Theussl added a comment -

        The patch has been applied indeed but the comments above indicate that the issue is not completely resolved. I'm closing it anyway as I don't have time to investigate, please open another ticket for any remaining issues.


          People

          • Assignee:
            Lukas Theussl
            Reporter:
            Phil Steitz
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: