Maven 1.x Changes Plugin
  1. Maven 1.x Changes Plugin
  2. MPCHANGES-19

changes.xml is empty when commited by prepare-release

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: 1.5.1
    • Labels:
      None
    • Environment:
      Windows XP SP1
      Maven 1.0
      3.0Ghz Intel P4, 1GB memory
    • Number of attachments :
      0

      Description

      The file changes.xml is commited as a blank file by the goal scm:prepare-release. When I look at the file after the goal completes, the file is correct.

      I noticed the output file is not closed, or flushed, in org.apache.maven.changes.ReleasedVersion.releaseVersion() of the changes plugin.

        Issue Links

          Activity

          Carlos Sanchez added a comment -

          Dupe of MPSCM-24

          Carlos Sanchez added a comment -

          I meant dupe of MPSCM-11


            People

            • Assignee:
              Carlos Sanchez
              Reporter:
              Paul Spencer
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: