Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.9
    • Fix Version/s: 1.9.1
    • Labels:
      None
    • Environment:
      Debian Sarge, Ubuntu Hoary, CVS 1.12.9 on the server
    • Number of attachments :
      0

      Description

      Apparently the date format change applied to CVS a while back continues to wreak havoc.

      I found the following mail very instructive (and fixed my issues):

      > The problems with cvs date handling reported in
      > http://jira.codehaus.org/browse/MAVEN-1447
      > have been fixed in netbeans version 4.1
      > http://www.netbeans.org/source/browse/javacvs/libsrc/org/netbeans/lib/cvsclient/command/log/LogInformation.java?r1=1.15&r2=1.16
      >
      > The current maven-1.1.-beta-2 is still shipping with a jar
      > called cvslib-3.6.jar

      > If one copies the ide5/modules/org-netbeans-lib-cvsclient.jar from a
      > netbeans 4.1 installation to ~/.maven/repository/netbeans/jars/cvslib-3.6.jar
      > then the problem goes away.
      >
      > Hope this helps
      > Tim Pizey

      It does help. I have been looking in JIRA, but I found all tickets related to this issue as being closed, So I log this ticket as a reminder to maybe update the dependencies to use the newer library.

      I apologize beforehand if this already has been done.

      Just for good measure, here is a typical stack dump :

      java.lang.Exception: Couldn't parse date 2005-09-19 09:07:43 +0000
      at org.netbeans.lib.cvsclient.util.BugLog.bug(BugLog.java:58)
      at org.netbeans.lib.cvsclient.command.log.LogInformation$Revision.setDateString(LogInformation.java:382)
      at org.netbeans.lib.cvsclient.command.log.LogBuilder.processRevisionDate(LogBuilder.java:273)
      at org.netbeans.lib.cvsclient.command.log.LogBuilder.parseLine(LogBuilder.java:134)
      at org.netbeans.lib.cvsclient.command.BuildableCommand.messageSent(BuildableCommand.java:86)
      at org.netbeans.lib.cvsclient.event.MessageEvent.fireEvent(MessageEvent.java:96)
      at org.netbeans.lib.cvsclient.event.EventManager.fireCVSEvent(EventManager.java:107)
      at org.netbeans.lib.cvsclient.response.MessageTaggedResponse.process(MessageTaggedResponse.java:39)
      at org.netbeans.lib.cvsclient.Client.handleResponse(Client.java:485)
      at org.netbeans.lib.cvsclient.Client.processRequests(Client.java:439)
      at org.netbeans.lib.cvsclient.command.log.LogCommand.execute(LogCommand.java:132)
      at org.netbeans.lib.cvsclient.Client.executeCommand(Client.java:533)
      at org.apache.maven.cvslib.CvsConnection.executeCommand(CvsConnection.java:90)
      at org.apache.maven.cvslib.CvsConnection.processCommand(CvsConnection.java:421)
      at org.apache.maven.cvslib.CvsChangeLogGenerator.getEntries(CvsChangeLogGenerator.java:100)
      at org.apache.maven.changelog.ChangeLog.generateEntries(ChangeLog.java:239)
      at org.apache.maven.changelog.ChangeLog.doExecute(ChangeLog.java:214)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:230)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:145)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      at org.apache.commons.jelly.tags.core.IfTag.doTag(IfTag.java:88)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      at org.apache.commons.jelly.tags.core.WhenTag.doTag(WhenTag.java:92)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.commons.jelly.TagSupport.invokeBody(TagSupport.java:233)
      at org.apache.commons.jelly.tags.core.ChooseTag.doTag(ChooseTag.java:84)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:279)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:135)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:79)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:110)
      at com.werken.werkz.Goal.fire(Goal.java:639)
      at com.werken.werkz.Goal.attain(Goal.java:575)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:671)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:488)
      at org.apache.maven.cli.App.main(App.java:1239)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)

        Activity

        Arnaud Heritier added a comment -

        This library is used in the changelog plugin.
        The problem is that there's only the cvslib 3.6 in ibiblio.
        Can we add a new one ?
        Can't we use our scm code ?

        stephane bouchet added a comment -

        Hi,

        Using maven 1.1-beta2 and last changelog plugin ( 1.9 ) i am still getting this issue.

        After looking at the plugin matrix on docs.codehaus, version 1.9 will be release in the next release of maven....

        Could it be possible to fix this in 1.9.1 and relese it with maven 1.1-b3 ???

        Best regards

        Lukas Theussl added a comment -

        You can make an upload request for cvslib-4.1 (or 5.0?) and we'll test it. I don't think it will make it into 1.1b3 though as we have a lot of other priorities still. In particular, a better use of Maven's scm code is planned for another changelog-plugin release before 1.1-final.

        Which version of cvs are you using? It seems that this issue only happens for certain cvs versions (see also MAVEN-1447), so just upgrading cvs might be a simpler solution?

        Emmanuel Venisse added a comment -
        stephane bouchet added a comment -

        I am using cvs version 1.12.9, but i cannot upgrade ( using a forge like sourceforge ) , i will ask to do it..

        So i updated the dependencies as Emmanuel provide, and it is working !

        thanks

        Lukas Theussl added a comment -

        Ok, cool. I am having some problems with ibiblio right now (I'm on a slow connection too) but I will test ASAP.

        Arnaud Heritier added a comment -

        If, we have only to update the dependency to make happy some users, I think we can quicly release a new version before the beta 3 (waiting a total rewritting using our scm components).

        Lukas Theussl added a comment -

        Applied in SVN.


          People

          • Assignee:
            Unassigned
            Reporter:
            Peter Tillemans
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: