Maven 1.x Changelog Plugin
  1. Maven 1.x Changelog Plugin
  2. MPCHANGELOG-65

VSS - Output Log Format, VssChangeLogParser.java

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.8.1
    • Fix Version/s: 1.8.2
    • Labels:
      None
    • Environment:
      maven-changelog-plugin v.1.8.1
      VSS v. 6.0
      Windows 2000 SP4
    • Number of attachments :
      0

      Description

      1. I was forsed to set explicitly date/time format in Control Panel "dd.MM.yy HH:mm:ss"

      • SimpleDateFormat is hardcoded in VssChangeLogParser.java

      2. I have following exception now:
      Caused by: java.lang.ArrayIndexOutOfBoundsException: 2
      at org.apache.maven.vsslib.VssChangeLogParser.processGetFile(VssChangeLogParser.java:221)
      at org.apache.maven.vsslib.VssChangeLogParser.parse(VssChangeLogParser.java:152)
      at org.apache.maven.changelog.AbstractChangeLogGenerator.start(AbstractChangeLogGenerator.java:405)

      I tried to execute SS.EXE as command, hope it will help in troubleshooting:
      ===========================================================================
      D:\dev\cruise\maven>set ssdir=\\MyVssServer\vss\SSSource
      D:\dev\cruise\maven>set ssuser=Fuad.Efendi
      D:\dev\cruise\maven>ss History $\MyApp\MyWebApp\src -R
      Building list for $/MyApp/MyWebApp/src......................
      .....................................

              • exception *****
                Version 4
                User: Fuad.Efendi Date: 2.06.05 Time: 12:48
                ServiceLocatorException.java deleted
              • LogManager.java *****
                Version 3
                User: Fuad.Efendi Date: 2.06.05 Time: 12:47
                Checked in $/MyApp/MyWebApp/src/com/abcd/catalog/util
                Comment: June 2, 2005,

      ..................

      How to download current source files? Probably I can fix smth
      Thanks!

        Activity

        Fuad Efendi added a comment -

        I found following in SS.EXE output:

        **********************
        Label: "BEFORE_RETROFITS"
        User: Funtick.Muallim Date: 24.05.05 Time: 10:58
        ... ... ...

        Modifications in VssChangeLogParser.java:
        =========================================
        BEFORE: private static final String START_FILE = "****";
        NOW: private static final String START_FILE = "***** "; //five stars, two spaces!

        And it works for me now...
        Thanks!


          People

          • Assignee:
            Unassigned
            Reporter:
            Fuad Efendi
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 1 day
              1d
              Remaining:
              Remaining Estimate - 1 day
              1d
              Logged:
              Time Spent - Not Specified
              Not Specified