Maven 1.x Artifact Plugin
  1. Maven 1.x Artifact Plugin
  2. MPARTIFACT-71

Can't deploy artifacts due to "reject HostKey" error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.9
    • Labels:
      None
    • Environment:
      Client=Win XP; Maven 1.1b3; deploying tasks 1.3-snapshot to maven-plugins at SourceForge
    • Number of attachments :
      0

      Description

      This is the high-level error info:

      plugin:repository-deploy:
      [echo] Deploying...
      Will deploy to 1 repository(ies): maven.plugins.sf.snapshots
      Deploying to repository: maven.plugins.sf.snapshots
      Failed to deploy to: maven.plugins.sf.snapshots Reason: org.apache.maven.wagon.authentication.AuthenticationException: Cannot connect. Reason: reject HostKey: shell.sourceforge.net
      org.apache.maven.wagon.authentication.AuthenticationException: Cannot connect. Reason: reject HostKey: shell.sourceforge.net
      at org.apache.maven.wagon.providers.ssh.AbstractSshWagon.openConnection(AbstractSshWagon.java:232)

      If I use m1.1b3-snapshot of 6/30 from Arnaud's website, it works. Any snapshot after that and the b3 release do not work - they have this problem.

      I think (but not sure) one key procedure to reproducing this is to start with clean repo and plugins install area: delete the .maven dir and any existing Maven program dir (the plugins must start with only the bundled ones).

        Issue Links

          Activity

          No work has yet been logged on this issue.

            People

            • Assignee:
              Arnaud Heritier
              Reporter:
              Jeff Jensen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: