Maven 1.x Artifact Plugin
  1. Maven 1.x Artifact Plugin
  2. MPARTIFACT-71

Can't deploy artifacts due to "reject HostKey" error

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 1.8
    • Fix Version/s: 1.9
    • Labels:
      None
    • Environment:
      Client=Win XP; Maven 1.1b3; deploying tasks 1.3-snapshot to maven-plugins at SourceForge
    • Number of attachments :
      0

      Description

      This is the high-level error info:

      plugin:repository-deploy:
      [echo] Deploying...
      Will deploy to 1 repository(ies): maven.plugins.sf.snapshots
      Deploying to repository: maven.plugins.sf.snapshots
      Failed to deploy to: maven.plugins.sf.snapshots Reason: org.apache.maven.wagon.authentication.AuthenticationException: Cannot connect. Reason: reject HostKey: shell.sourceforge.net
      org.apache.maven.wagon.authentication.AuthenticationException: Cannot connect. Reason: reject HostKey: shell.sourceforge.net
      at org.apache.maven.wagon.providers.ssh.AbstractSshWagon.openConnection(AbstractSshWagon.java:232)

      If I use m1.1b3-snapshot of 6/30 from Arnaud's website, it works. Any snapshot after that and the b3 release do not work - they have this problem.

      I think (but not sure) one key procedure to reproducing this is to start with clean repo and plugins install area: delete the .maven dir and any existing Maven program dir (the plugins must start with only the bundled ones).

        Issue Links

          Activity

          Jeff Jensen added a comment -

          Works for me! Great job Arnaud!

          I ran plugin:download as you have above, then ran maven -Dmaven.repo.list=maven.plugins.sf.snapshots plugin:repository-deploy, and it deployed.

          Arnaud Heritier added a comment -

          It's fixed. Host key is always accepted.
          scpexe protocol works for me. If you encounter again this bug with scpexe, please open a new bug.

          Arnaud Heritier added a comment -

          Jeff found that this bug exists also with the sftp protocol

          Arnaud Heritier added a comment -

          Fixed also for SFTP protocol. A new snapshot of the plugin is deployed with this protocol

          Jeff Jensen added a comment -

          Good job Arnaud, the new snapshot works for SFTP.


            People

            • Assignee:
              Arnaud Heritier
              Reporter:
              Jeff Jensen
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: