Maven 1.x Artifact Plugin
  1. Maven 1.x Artifact Plugin
  2. MPARTIFACT-51

Issue with dependency properties in POM when deploying

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.5.1
    • Fix Version/s: 1.5.2
    • Labels:
      None
    • Environment:
      Maven 1.1 from tunk (6th of June).
    • Number of attachments :
      0

      Description

      Here's what happens when I try to install a WAR:

      [...]
      war:install:
      [echo] Installing...
      Uploading to mdn/wars/qotd-web-1.0.war:
      .................... (283K)

      LA CONSTRUCTION A ╚CHOU╚
      org.apache.maven.werkz.UnattainableGoalException: Unable to obtain goal [war:install] – C:\Documents and Settings\Vincent Massol\
      .maven\cache\maven-artifact-plugin-1.5.1\plugin.jelly:62:-1: <artifact:artifact-install> Error getting the project as a string
      at org.apache.maven.werkz.Goal.fire(Goal.java:663)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      org.apache.commons.jelly.JellyTagException: C:\Documents and Settings\Vincent Massol\.maven\cache\maven-artifact-plugin-1.5.1\plug
      in.jelly:62:-1: <artifact:artifact-install> Error getting the project as a string
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:193)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:102)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:79)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Caused by: org.apache.maven.MavenException: Error getting the project as a string
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.getRewrittenPom(DefaultArtifactDeployer.java:202)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.handleInstall(DefaultArtifactDeployer.java:273)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.install(DefaultArtifactDeployer.java:242)
      at org.apache.maven.artifact.deployer.DeployBean.install(DeployBean.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:180)
      ... 38 more
      Root cause
      org.apache.maven.MavenException: Error getting the project as a string
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.getRewrittenPom(DefaultArtifactDeployer.java:202)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.handleInstall(DefaultArtifactDeployer.java:273)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.install(DefaultArtifactDeployer.java:242)
      at org.apache.maven.artifact.deployer.DeployBean.install(DeployBean.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:180)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:102)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:79)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      — Nested Exception —
      org.codehaus.plexus.util.xml.pull.XmlPullParserException: TEXT must be immediately followed by END_TAG and not START_TAG (position
      : START_TAG seen ...<entry>\n <key>... @39:18)
      at org.codehaus.plexus.util.xml.pull.MXParser.nextText(MXParser.java:1059)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.parseDependency(MavenXpp3Reader.java:354)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.parseModel(MavenXpp3Reader.java:856)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.read(MavenXpp3Reader.java:1621)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.getRewrittenPom(DefaultArtifactDeployer.java:176)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.handleInstall(DefaultArtifactDeployer.java:273)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.install(DefaultArtifactDeployer.java:242)
      at org.apache.maven.artifact.deployer.DeployBean.install(DeployBean.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:180)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:102)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:79)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Root cause
      org.apache.maven.MavenException: Error getting the project as a string
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.getRewrittenPom(DefaultArtifactDeployer.java:202)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.handleInstall(DefaultArtifactDeployer.java:273)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.install(DefaultArtifactDeployer.java:242)
      at org.apache.maven.artifact.deployer.DeployBean.install(DeployBean.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:180)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:102)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:79)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      — Nested Exception —
      org.codehaus.plexus.util.xml.pull.XmlPullParserException: TEXT must be immediately followed by END_TAG and not START_TAG (position
      : START_TAG seen ...<entry>\n <key>... @39:18)
      at org.codehaus.plexus.util.xml.pull.MXParser.nextText(MXParser.java:1059)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.parseDependency(MavenXpp3Reader.java:354)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.parseModel(MavenXpp3Reader.java:856)
      at org.apache.maven.model.io.xpp3.MavenXpp3Reader.read(MavenXpp3Reader.java:1621)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.getRewrittenPom(DefaultArtifactDeployer.java:176)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.handleInstall(DefaultArtifactDeployer.java:273)
      at org.apache.maven.artifact.deployer.DefaultArtifactDeployer.install(DefaultArtifactDeployer.java:242)
      at org.apache.maven.artifact.deployer.DeployBean.install(DeployBean.java:160)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at org.apache.commons.jelly.impl.DynamicBeanTag.doTag(DynamicBeanTag.java:180)
      at org.apache.commons.jelly.impl.StaticTagScript.run(StaticTagScript.java:102)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.commons.jelly.impl.DynamicTag.doTag(DynamicTag.java:79)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.Goal.attainPrecursors(Goal.java:505)
      at org.apache.maven.werkz.Goal.attain(Goal.java:590)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.jelly.tags.maven.ReactorTag.doTag(ReactorTag.java:368)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.werkz.WerkzProject.attainGoal(WerkzProject.java:210)
      at org.apache.maven.jelly.tags.werkz.MavenAttainGoalTag.doTag(MavenAttainGoalTag.java:114)
      at org.apache.commons.jelly.impl.TagScript.run(TagScript.java:247)
      at org.apache.commons.jelly.impl.ScriptBlock.run(ScriptBlock.java:95)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag.runBodyTag(MavenGoalTag.java:78)
      at org.apache.maven.jelly.tags.werkz.MavenGoalTag$MavenGoalAction.performAction(MavenGoalTag.java:109)
      at org.apache.maven.werkz.Goal.fire(Goal.java:656)
      at org.apache.maven.werkz.Goal.attain(Goal.java:592)
      at org.apache.maven.plugin.PluginManager.attainGoals(PluginManager.java:693)
      at org.apache.maven.MavenSession.attainGoals(MavenSession.java:263)
      at org.apache.maven.cli.App.doMain(App.java:511)
      at org.apache.maven.cli.App.main(App.java:1258)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:324)
      at com.werken.forehead.Forehead.run(Forehead.java:551)
      at com.werken.forehead.Forehead.main(Forehead.java:581)
      Fichier... C:\Documents and Settings\Vincent Massol\.maven\cache\maven-multiproject-plugin-1.4\plugin.jelly
      ╚lement... maven:reactor
      Ligne..... 218
      Colonne... -1
      Unable to obtain goal [war:install] – C:\Documents and Settings\Vincent Massol\.maven\cache\maven-artifact-plugin-1.5.1\plugin.je
      lly:62:-1: <artifact:artifact-install> Error getting the project as a string
      Temps total : 21 secondes
      Fini le : lundi 6 juin 2005 16:04:49 CEST

        Issue Links

          Activity

          Arnaud Heritier added a comment -

          I have the same error at home but not at work.
          I didn't yet investigate ....


            People

            • Assignee:
              Brett Porter
              Reporter:
              Vincent Massol
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: