Maven 1.x Artifact Plugin
  1. Maven 1.x Artifact Plugin
  2. MPARTIFACT-38

scpexe with pscp and plink fails with multiple args

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.4
    • Fix Version/s: 1.4.1
    • Labels:
      None
    • Environment:
      win2k, j2re1.4.2_05, maven-1.0
    • Number of attachments :
      1

      Description

      defining more than one attribute in maven.repo.[name].ssh.args or maven.repo.[name].scp.args leads to an unknown option error in pscp, plink fails silently.
      example:
      maven.repo.[name].scp.args=-2 -P 50022

      ERROR>pscp: unknown option "-2 -P 50022"
      ERROR> try typing just "pscp" for help

      assigning ports with maven.repo.[name].port=50022 doesn't help because plink and pscp both uses the "-P" to define the port

      the problem is the runtime.exec call in ScpExeDeployer who uses a String[] instead of String

      using a batch file as workaround makes the args property obsolete

        Activity

        Markus Nolte added a comment -

        this patch fixed the described issue, I've also added streamGobbler for executeSimpleCommand and a recursive chmod g+w for the maven.repo.[name].directory path top level parent dir

        Brett Porter added a comment -

        patch wouldn't apply.

        Also, don't want to chgrp/chmod -R the entire directory tree - need an alternate solution for this.


          People

          • Assignee:
            Brett Porter
            Reporter:
            Markus Nolte
          • Votes:
            0 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: