Maven 1.x Artifact Plugin
  1. Maven 1.x Artifact Plugin
  2. MPARTIFACT-20

deploy:copy-deps fails if a project has no dependencies

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      maven 1.0rc3, win2k, jdk1.4.2
    • Number of attachments :
      0

      Description

      deploy:copy-deps fails when a project has no dependencies:

      [echo] Calling deploy:copy-deps
      [mkdir] Created dir: C:\maven\sources\maven\lib

      BUILD FAILED
      File...... C:\Documents and Settings\mmattox\.maven\plugins\maven-deploy-plugin-1.3\plugin.jelly
      Element... ant:copy
      Line...... 161
      Column.... 49
      Specify at least one source - a file or a fileset.
      Total time: 14 minutes 16 seconds
      Finished at: Wed Jun 16 11:36:11 CEST 2004

        Activity

        Hide
        Michael added a comment -

        This was originally opened as a multiproject bug, so see this issue for some more comments:

        http://jira.codehaus.org/browse/MPMULTIPROJECT-35

        Show
        Michael added a comment - This was originally opened as a multiproject bug, so see this issue for some more comments: http://jira.codehaus.org/browse/MPMULTIPROJECT-35

          People

          • Assignee:
            Brett Porter
            Reporter:
            Michael
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: