Maven 1.x AppServer Plugin
  1. Maven 1.x AppServer Plugin
  2. MPAPPSERVER-7

some properties do not play nice with maven console or reinvoked goals

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      A) maven appserver:install
      1) start maven console in terminal A
      2) at terminal A console, execute appserver:stop
      Gives message like:
      Maven has determined your <servername> appserver instance is
      installed in directory <dirname> and not started using socket
      <socketport> on host <appserver host>

      3) execute maven appserver:start in terminal B, leaving console in A open
      4) with appserver now started, execute appserver:stop in maven console again running in terminal A
      5) message still says:
      Gives message like:
      Maven has determined your <servername> appserver instance is
      installed in directory <dirname> and not started using socket
      <socketport> on host <appserver host>

      However server is now started.

      This has to do with properties being set using ant the first time appserver:stop is called. Properties set by ant are not removable or resettable by design, so the solution is to set the properties via jelly.

        Activity

        Peter Lynch added a comment -

        Checking in plugin.jelly;
        /home/cvs/maven-plugins/appserver/plugin.jelly,v <-- plugin.jelly
        new revision: 1.9; previous revision: 1.8
        done


          People

          • Assignee:
            Peter Lynch
            Reporter:
            Peter Lynch
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Due:
              Created:
              Updated:
              Resolved:

              Time Tracking

              Estimated:
              Original Estimate - 2 hours
              2h
              Remaining:
              Remaining Estimate - 2 hours
              2h
              Logged:
              Time Spent - Not Specified
              Not Specified