Mojo
  1. Mojo
  2. MOJO-656

Error details from FileUtils.copyFile are not rethrown in NativeLinkMojo.getDependencyFile

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: native
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      IOExceptions are caught in NativeLinkMojo.getDependencyFile is copying the dependency and a new MojoExecutionException is thrown, but no details from the IOException are included, nor is any context surrounding the exception (such as what was being copied and to where it was being copied).

      The attached patch includes the original IOException as the cause when creating the MojoExecutionException and also includes details on the source and destination files in the exception message.

        Activity

        Dan Tran added a comment -

        applied the patch at rev 5848. Thanks


          People

          • Assignee:
            Dan Tran
            Reporter:
            DJ Gregor
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: