Maven Project Web Site
  1. Maven Project Web Site
  2. MNGSITE-81

Wrong Root Element in profiles.xml examples used

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Labels:
      None
    • Environment:
      All
    • Number of attachments :
      0

      Description

      On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use

      <project xmlns="http://maven.apache.org/POM/4.0.0"
        xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
        xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                            http://maven.apache.org/xsd/maven-4.0.0.xsd">
        ...

      But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

        Issue Links

          Activity

          Benjamin Bentmann added a comment -

          The page your refer to is titled "POM Reference", i.e. is about profiles in the POM. As such, the examples given on this page are correct.

          What would be needed is a document "Profiles Reference" or similar, that addresses the profiles.xml itself.

          It is needed to change this into <projectXmls ...>.

          As per the XSD, <profilesXml> would work better

          Herve Boutemy made changes -
          Field Original Value New Value
          Link This issue relates to MNGSITE-102 [ MNGSITE-102 ]
          Herve Boutemy made changes -
          Description On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use
          <project xmlns="http://maven.apache.org/POM/4.0.0"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                                http://maven.apache.org/xsd/maven-4.0.0.xsd">
            ...
          But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

          On the Web-Site http://maven.apache.org/pom.html#Profiles there are examples which use
          {code:xml}<project xmlns="http://maven.apache.org/POM/4.0.0"
            xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"
            xsi:schemaLocation="http://maven.apache.org/POM/4.0.0
                                http://maven.apache.org/xsd/maven-4.0.0.xsd">
            ...{code}
          But this will produce an error with Maven 2.1.0 ....It is needed to change this into <projectXmls ...>.

          Herve Boutemy made changes -
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Cannot Reproduce [ 5 ]

            People

            • Assignee:
              Unassigned
              Reporter:
              Karl-Heinz Marbaise
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: