Maven Integration for Eclipse
  1. Maven Integration for Eclipse
  2. MNGECLIPSE-713

when a project depends on a war project, the plugin tries to make the dependant war project a j2ee utility project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Duplicate
    • Affects Version/s: 0.9.5
    • Fix Version/s: 0.9.7
    • Component/s: WTP integration
    • Labels:
      None
    • Number of attachments :
      0

      Description

      when a project depends on a war project, the plugin tries to make the dependant war project a j2ee utility project

      this means that it tries to make it both a utility project and a web project, and eclipse complains about this.

      we depend on war projects for war overlays and for assembly projects.

        Issue Links

          Activity

          Eugene Kuleshov added a comment -

          Dylan, please provide sample test projects required to reproduce this issue. See wiki page for more details. Thanks.

          Eugene Kuleshov added a comment -

          This actually look like a duplicate of MNGECLIPSE-597 and might be already covered in the work done for MNGECLIPSE-688

          Fred Bricon added a comment -

          Changing status to duplicate

          Fred Bricon added a comment -

          duplicate of MNGECLIPSE-597


            People

            • Assignee:
              Unassigned
              Reporter:
              Dylan Schell
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: