Maven
  1. Maven
  2. MNG-836

plugin dependencies cannot be resolved

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0-beta-1
    • Fix Version/s: 2.0-beta-1
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Try: deleting ~/.m2/repository/org/codehaus and then build maven-model.

      Somehow plugin dependencies are not resolved; weird that this doesn't occur more often.
      This is because in DefaultPluginManager the verifyPlugin method calls checkRequiredMavenVersion
      with just the PluginArtifactRepositories. The checkRequiredMavenVersion resolves the plugin and/or
      its dependencies but does not have access to the normal artifact repositories, so only plugin repositories
      can be searched for the plugin's dependencies.

      Modified the verifyPlugin method to add the RemoteArtifactRepositories to the list.

        Issue Links

          Activity

          Kenney Westerhof added a comment -

          First I thought this was because of a duplicate repository <id>; changing it fixed it. But I couldn't
          reproduce it again, and after fixing it it was something else; so I renamed this issue.

          Brett Porter added a comment -

          was a regression caused by MNG-757, rolled back

          John Casey added a comment -

          Do we have a test to prevent this regression in future, or are we no better off than before??

          Brett Porter added a comment -

          we're presently back to where we were, but the above can be used to form a test case

          Kenney Westerhof added a comment -

          I fixed this in r278736, 2005-09-05...


            People

            • Assignee:
              Brett Porter
              Reporter:
              Kenney Westerhof
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved:

                Time Tracking

                Estimated:
                Original Estimate - 1 hour
                1h
                Remaining:
                Remaining Estimate - 1 hour
                1h
                Logged:
                Time Spent - Not Specified
                Not Specified