Maven
  1. Maven
  2. MNG-5245

upgrade default plugins versions

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.4
    • Fix Version/s: 3.1.0-alpha-1
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Issue Links

        Activity

        Hide
        Olivier Lamy added a comment -

        surefire 2.12 r1244153

        Show
        Olivier Lamy added a comment - surefire 2.12 r1244153
        Hide
        Falko Modler added a comment -

        I am strongly opposed to using surefire 2.12 because of this bug which affects many users:
        http://jira.codehaus.org/browse/SUREFIRE-827

        Show
        Falko Modler added a comment - I am strongly opposed to using surefire 2.12 because of this bug which affects many users: http://jira.codehaus.org/browse/SUREFIRE-827
        Hide
        Stanilslav Spiridonov added a comment -

        Resolved in 2.12.1

        Show
        Stanilslav Spiridonov added a comment - Resolved in 2.12.1
        Hide
        Olivier Lamy added a comment -

        2.12.1 r1369644

        Show
        Olivier Lamy added a comment - 2.12.1 r1369644
        Hide
        Karl-Heinz Marbaise added a comment -

        upgrade done in r1410570 (by Kristian Rosenvold).

        • components.xml
        • maven-clean-plugin up to 2.5
        • maven-site-plugin up to 3.1
        • default-bindings.xml
        • maven-install-plugin up to 2.4
        • maven-resources-plugin up to 2.6
        • maven-compiler-plugin up to 2.5.1
        • maven-surefire-plugin up to 2.12.4
        • maven-jar-plugin up to 2.4
        • maven-plugin-pugin up to 3.2
        • maven-war-plugin up to 2.3
        • maven-ear-plugin up to 2.8
        Show
        Karl-Heinz Marbaise added a comment - upgrade done in r1410570 (by Kristian Rosenvold). components.xml maven-clean-plugin up to 2.5 maven-site-plugin up to 3.1 default-bindings.xml maven-install-plugin up to 2.4 maven-resources-plugin up to 2.6 maven-compiler-plugin up to 2.5.1 maven-surefire-plugin up to 2.12.4 maven-jar-plugin up to 2.4 maven-plugin-pugin up to 3.2 maven-war-plugin up to 2.3 maven-ear-plugin up to 2.8
        Hide
        Olivier Lamy added a comment -
        Show
        Olivier Lamy added a comment - http://svn.apache.org/r1410570
        Hide
        Herve Boutemy added a comment -

        maven-site-plugin up to 3.2 in ac213ec5

        Show
        Herve Boutemy added a comment - maven-site-plugin up to 3.2 in ac213ec5

          People

          • Assignee:
            Olivier Lamy
            Reporter:
            Olivier Lamy
          • Votes:
            0 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: