Maven
  1. Maven
  2. MNG-5120

Reg:How to build a project when building another project implicitely

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: None
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      When we are building a project and that project contains dependency from another project then we have to add the dependency explicitly . Instead of doing like that is there is any way to build the dependent project while building the main project implicitly that is we have to take the project name from the command prompt and that will be dependent project name and that project has to be build first and then that dependency will be added to our main project........

        Activity

        Art O Cathain added a comment -

        You can use the --also-make-dependents or --also-make flags of the mvn command. You should close this ticket, it's not a bug.


          People

          • Assignee:
            Unassigned
            Reporter:
            krishna prasad vurapalli
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: