Maven 2 & 3
  1. Maven 2 & 3
  2. MNG-5113

NullPointerException on javadoc site generation

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0.3
    • Fix Version/s: 3.0.4
    • Component/s: Sites & Reporting
    • Labels:
      None
    • Environment:
      Archlinux 2.6.36 (x86)
    • Complexity:
      Intermediate
    • Number of attachments :
      2

      Description

      Dear codehaus developers,

      Today I encountered a pretty serious error, while trying to generate javadocs for my code. This was the first time I added the reporting part to my pom. Site generation worked fine without this part. After I added this part, maven gave me a NullPointerException.
      It was very easy for me to reproduce the bug. I created an empty directory and put the following pom there:

      pom.xml
      <?xml version="1.0"?>
      <project xsi:schemaLocation="http://maven.apache.org/POM/4.0.0 http://maven.apache.org/xsd/maven-4.0.0.xsd" xmlns="http://maven.apache.org/POM/4.0.0"
          xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
        <modelVersion>4.0.0</modelVersion>
        <groupId>Test</groupId>
        <artifactId>test</artifactId>
        <version>1.0-SNAPSHOT</version>
      
        <reporting>
          <plugins>
            <plugin>
              <groupId>org.apache.maven.plugins</groupId>
              <artefactId>maven-javadoc-plugin</artefactId>
              <version>2.8</version>
            </plugin>
          </plugins>
        </reporting>
      </project>
      

      Then I ran:

      mvn site

      I've attached the debugging output and this example pom to this report.

      Best regards,

      Chris

      1. debug.log
        3 kB
        Christian
      2. pom.xml
        0.6 kB
        Christian

        Activity

        Christian added a comment -

        Ok, all this was caused by a little typo. I typed artefact instead of artifact. I didn't noticed that, at the time of writing. After I submitted the bug, I added the plugin to the build plugin list, this generated an error, saying that I had a typo in my pom. So this was all by fault.
        Still, I'll leave the issue open, since I the NullPointerException thrown, shouldn't have been thrown. This should've been the typo-error (Non-parsable POM), which I got after adding the plugin to the build section.

        Chris.

        Benjamin Bentmann added a comment -

        Fixed in r1151420.


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Christian
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: