Maven
  1. Maven
  2. MNG-5090

Maven End Users should be able to control the execution order of plugins without creating a custom Lifecycle and Package Type

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.0.3
    • Fix Version/s: None
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      As confirmed by Benjamin Bentmann, Maven end users are currently limited in the control they have over the execution order of plugins bound to the same build phase unless they author their own custom Lifecycle and use a custom Package Type.

      While Maven is intended to be declarative rather than procedural and to do most of its work based on sensible defaults, it is a basic requirement of any build system to allow the end user to control the order in which actions occur and to do so with a minimum of effort.

      It should be possible to configure a plugin, simply and entirely within the POM, such that it will execute before, or even between, plugins defined by the lifecycle mappings.

        Issue Links

          Activity

          James Garrison added a comment -

          How do I vote to reopen this issue? I should not have to write my own plugin to sequence several steps in the build process that are required for Continuous Integration (test database setup and population).


            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Graham Lea
            • Votes:
              0 Vote for this issue
              Watchers:
              2 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: