Maven
  1. Maven
  2. MNG-4881

Problem resolving dependency range with SNAPSHOT

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Not A Bug
    • Affects Version/s: 3.0
    • Fix Version/s: None
    • Component/s: Dependencies
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      In my pom I have this dependency:

      <dependency>
      <groupId>MyGroupId</groupId>
      <artifactId>MyArtifactId</artifactId>
      <version>[2.0.0-SNAPSHOT,)</version>
      </dependency>

      Why running maven I have:

      org.apache.maven.lifecycle.LifecycleExecutionException:
      Failed to execute goal on project rva-core:
      Couldn't find a version in [2.0.0-alpha-14, 2.0.0-alpha-15, 2.0.0-alpha-16]
      to match range [2.0.0-SNAPSHOT,) MyGroupId:MyArtifactId:jar:null

      Maybe 2.0.0-SNAPSHOT is greater then other version present on artifact repository?

        Issue Links

          Activity

          Benjamin Bentmann added a comment -

          2.0.0-alpha-X < 2.0.0-beta-X < 2.0.0-SNAPSHOT < 2.0.0

          Raffaele Verre added a comment -

          maven2 works differently than maven3?
          Maven2 resolve the dipendency without problems with the last alpha

          Benjamin Bentmann added a comment -

          "Not a bug" means works as intended.

          Raffaele Verre added a comment -

          sorry but it means that the method of resolution has changed?
          so [2.0.0-SNAPSHOT,) for me is no longer good?


            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Raffaele Verre
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: