Maven
  1. Maven
  2. MNG-4842

[regression] Repositories discovered in dependency POMs override repositories configured for original resolution request of POM

    Details

    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      When processing/building a dependency POM during transitive resolution, the repos declared in that POM erroneously take precedence over the repos specified for the original request when parent POMs of said POM need to be resolved. The potential results of this bug are network trips to wrong repos or resolution failures due to wrong repo policies being applied.

        Activity

        Benjamin Bentmann added a comment -

        Fixed in r1002852.

        Benjamin Bentmann made changes -
        Field Original Value New Value
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Benjamin Bentmann [ bentmann ]
        Fix Version/s 3.0 [ 13142 ]
        Resolution Fixed [ 1 ]

          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Benjamin Bentmann
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: