Maven
  1. Maven
  2. MNG-4836

Incorrect recursive expression cycle errors (update plexus-interpolation)

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-beta-3
    • Fix Version/s: 3.0
    • Labels:
      None
    • Environment:
      JDK 6u21, Ubuntu
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Actual:

      $ mvn -f .../mojo-archetypes/ear-javaee6/src/main/resources/archetype-resources/pom.xml versions:help
      ...
      [ERROR]     Resolving expression: '${version}': Detected the following recursive expression cycle: [version] -> [Help 2]
      [ERROR]     Resolving expression: '${artifactId}': Detected the following recursive expression cycle: [artifactId, version] -> [Help 2]
      [ERROR]     Resolving expression: '${groupId}': Detected the following recursive expression cycle: [groupId, artifactId, version] -> [Help 2]
      ...
      

      Expected:

      ...
      [ERROR]     Resolving expression: '${version}': Detected the following recursive expression cycle: [version] -> [Help 2]
      [ERROR]     Resolving expression: '${artifactId}': Detected the following recursive expression cycle: [artifactId] -> [Help 2]
      [ERROR]     Resolving expression: '${groupId}': Detected the following recursive expression cycle: [groupId] -> [Help 2]
      ...
      

      PLXCOMP-159 is responsible (confirmed by substituting patched JAR). I am not positive but I believe this is also the cause of a critical (if sporadic) error in the NetBeans embedder, starting to appear I think when RC1 was integrated (maybe RC2): https://netbeans.org/bugzilla/show_bug.cgi?id=190530

      PLXCOMP-158 is also related.

      Please consider producing a new release of plexus-interpolation containing these two patches and using it in Maven 3.0 RC3.

        Issue Links

          Activity

          Benjamin Bentmann added a comment -

          Fixed in r1000611.


            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Jesse Glick
            • Votes:
              0 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: