Maven
  1. Maven
  2. MNG-4825

Relative path errors could be more explicit

    Details

    • Type: Improvement Improvement
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-beta-3
    • Fix Version/s: 3.0
    • Component/s: Logging
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      See the exceptions in MNG-4824.

      This was caused by a default relative path of '../pom.xml' which was not correct. Maven 2.x ignored it and went to the repository, but as specified in the compatibility notes Maven 3 fails. The exception should state that it was a non-resolvable parent because it is not in the repository and not found at the relative path of '../pom.xml'

        Activity

        Benjamin Bentmann added a comment -

        Improved in r998850.


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: