Maven 2 & 3
  1. Maven 2 & 3
  2. MNG-4818

NPE in legacy.DefaultWagonManager.getArtifact

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0
    • Fix Version/s: 3.0
    • Labels:
      None
    • Environment:
      At revision 998131; 1.6.0_21 (32-bit); win7ent-x64
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      1. mvn archetype:create (with your favorite -DgroupId etc)
      2. add some non-local dependency to the pom (I used commons-jexl:2.0.1)
      3. mvn idea:idea
      4. kaboom

      The problem is that the Logger is declared as @Requirement but it is evidently not being provided (any path leading to a logging statement yields the NPE)

      I regret that I don't know enough plexus-voodoo to even create a TestCase for this.

      1. bug.log
        14 kB
        Matthew Daniel

        Activity

        Stuart McCulloch added a comment -

        I can't recreate this error with 3.0-RC1 (https://repository.apache.org/content/repositories/maven-030/org/apache/maven/apache-maven/3.0-RC1/)
        Can you try to recreate it with that release? Also in your test were you using a clean snapshot build of Maven3 or did you have local changes?

        Matthew Daniel added a comment -

        I was using a clean build of Maven-3 out of Subversion, yes, but I will be glad to test it with 3.0-RC1 and see what happens. I'll do that tomorrow, since my work machine has all the toys on it.

        Matthew Daniel added a comment -

        My sincere apologies, it appears that I left out "-DdownloadSources=true" from step 3.

        The good news is that yes, I experience this on 3.0-RC1 also.

        Just for clarity, I'll repeat the correct reproduction steps:

        1. mkdir \tmp\foo
        2. cd \tmp\foo
        3. mvn -DgroupId=my.group -DartifactId=myart -Dpackage=com.example.foo -Dpackaging=jar archetype:create
        4. cd myart
        5. edit pom.xml and add dependency (org.apache.commons:commons-jexl:2.0.1:jar) with no scope
        6. rmdir /s /q %M2_LOCAL_REPO%\org\apache\commons\commons-jexl
        7. mvn -e -DdownloadSources=true idea:idea

        Benjamin Bentmann added a comment -

        Fixed in r998861. Actually caused by a bad component which asked for injection into clashing private fields.


          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Matthew Daniel
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: