Maven 2 & 3
  1. Maven 2 & 3
  2. MNG-4466

Plugin Metaversion Compatibility

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-alpha-4
    • Fix Version/s: 3.0-alpha-6
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      According to the compatibility notes at http://cwiki.apache.org/MAVEN/maven-3x-compatibility-notes.html:

      "For the sake of reproducible builds, Maven 3.x no longer supports usage of [the RELEASE and LATEST] metaversions in the POM."

      LATEST is working fine for me in alpha-4.

        Issue Links

          Activity

          Benjamin Bentmann added a comment -

          Strangely this somehow got back working since then it seems. Anyway, the statement stands, those metaversions should not be used. Extended the model validator in r883537 to ban them.


            People

            • Assignee:
              Benjamin Bentmann
              Reporter:
              Fernando Ribeiro
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: