Maven
  1. Maven
  2. MNG-4235

[regression] Maven 2.2.0 produces invalid checksums during deployment to secured HTTP repo

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.2.0
    • Fix Version/s: 2.2.1
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Issue Links

        Activity

        John Casey made changes -
        Field Original Value New Value
        Fix Version/s 2.2.1 [ 15328 ]
        Kenneth Flynn added a comment -

        I am definitely seeing this for all our Maven projects. Had to revert to an earlier version to avoid this. I can provide more details if required/reproduction.

        Benjamin Bentmann made changes -
        Summary [regression] Maven 2.2.0 produces invalid checksums [regression] Maven 2.2.0 produces invalid checksums during deployment to secured HTTP repo
        Benjamin Bentmann made changes -
        Link This issue is related to MNG-4236 [ MNG-4236 ]
        Benjamin Bentmann added a comment -

        An IT is online. The checksum produced by Maven 2.2.0 equals the checksum of twice the input data, so this seems related to MNG-4236.

        John Casey added a comment -

        This SHOULD mean that the checksum error should happen also for the very first file transferred for any given deployment in a Maven 2.1.0 environment. It seems that the Sun implementation sends the first transfer twice, then caches authentication and uses it for preemptive authentication in subsequent transfers.

        We should check this out under the above circumstances.

        John Casey made changes -
        Link This issue relates to WAGON-277 [ WAGON-277 ]
        John Casey added a comment -

        This WAGON issue is meant to track the longer-term efforts to solve the problem for the httpclient-based wagon, after the MNG issue is closed. We can close the MNG issue without closing the WAGON issue since we're going back to the lightweight-http wagon by default.

        John Casey added a comment -

        Reverting to use of lightweight-http wagon by default, while still enabling the use of the httpclient-driven wagon if properly configured. We're tracking the long-term solution to the problem in the httpclient-driven wagon in WAGON-277.

        John Casey made changes -
        Assignee John Casey [ jdcasey ]
        Resolution Fixed [ 1 ]
        Status Open [ 1 ] Closed [ 6 ]
        John Casey made changes -
        Link This issue is related to MNG-4254 [ MNG-4254 ]
        John Casey added a comment -

        MNG-4254 provides a stop-gap until the issues can be sorted out in the WAGON project itself.

        Benjamin Bentmann made changes -
        Link This issue relates to MNG-4301 [ MNG-4301 ]
        Benjamin Bentmann made changes -
        Link This issue is related to WAGON-304 [ WAGON-304 ]
        Benjamin Bentmann made changes -
        Link This issue relates to WAGON-277 [ WAGON-277 ]

          People

          • Assignee:
            John Casey
            Reporter:
            John Casey
          • Votes:
            1 Vote for this issue
            Watchers:
            2 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: