Maven 2 & 3
  1. Maven 2 & 3
  2. MNG-4184

[regression] maven2.1 fails with cyclic dependency in case of extension/dependency for report-plugin to reactor-project

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.1.0
    • Fix Version/s: 2.2.0
    • Component/s: Dependencies
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      In my project (https://m-m-m.svn.sourceforge.net/svnroot/m-m-m/trunk/)
      I am doing exactly what maven-checkstyle-plugin suggests as best practice for multi-module-builds:
      http://maven.apache.org/plugins/maven-checkstyle-plugin/examples/multi-module-config.html

      Howerver when I upgrade to maven 2.1 my build does not work anymore, while maven 2.0.10 works fine:

      [INFO] The projects in the reactor contain a cyclic reference: Edge between 'Vertex

      {label='net.sf.m- m-m:mmm-setup'}

      ' and 'Vertex

      {label='net.sf.m-m-m:mmm-setup'}

      ' introduces to cycle in the graph net.s
      f.m-m-m:mmm-setup --> net.sf.m-m-m:mmm-setup

      Indeed the module mmm-setup inherits from the toplevel-pom and therefore has a maven-checkstyle-plugin
      with a dependency on itself. However this worked with maven 2.0.x and if this is NOT going to be
      "fixed" in 2.1, you need to supply an acceptable workaround and update instructions such as
      the one linked above. Please also note that such config-moudles (net.sf.m-m-m:mmm-setup or
      com.example.whizbang:build-tools) should typically be available in IDE and other modules might
      depend on them so they have to be part of the reactor for eclipse:eclipse.

        Issue Links

          Activity

          John Casey added a comment -

          this sounds like a regression, and we'll need to either fix it or supply adequate documentation for why compat with 2.0.x has been broken.

          John Casey added a comment -

          This has been fixed for 2.2.0

          Jörg Hohwiller added a comment -

          Confirmed after retest with 2.2.0.

          However if I add the artifact as <extension> as suggested here:
          http://mojo.codehaus.org/findbugs-maven-plugin/2.0.1/examples/multi-module-config.html

          then it still fails with the same problem.

          Jörg Hohwiller added a comment - - edited

          Same problem occurs in maven 2.2 if you have 3 levels of poms:

          • root (with dependency on module setup, modules=child1, ...)
          • child1 (parent=root, modules=setup,...)
          • setup (root=child1)
          Paul Benedict added a comment -

          This issue was reopened, but I created MNG-4253 to track the <extension> bug because 2.2 was already in RC mode. Anyway, if the new issue is not needed, please close.

          John Casey added a comment -

          Tracking the slightly different variety of this problem in a different issue now, for the next release.


            People

            • Assignee:
              John Casey
              Reporter:
              Jörg Hohwiller
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: