Maven
  1. Maven
  2. MNG-3776

Namespace misspelled in settings.xml

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Trivial Trivial
    • Resolution: Fixed
    • Affects Version/s: 2.1.0-M1
    • Fix Version/s: 2.0.11, 2.2.0
    • Component/s: Settings
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      The conf/settings.xml file delivered in apache-maven-2.1.0-m1 contains a misspelling:

      <settings xmlns="http://maven.apache.org/settings/1.0.0" 
                xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                xsi:schemaLocation="http://maven.apache.org/setrings/1.0.0 
                http://maven.apache.org/xsd/settings-1.0.0.xsd">
      

      The namespace in xsi:schemaLocation contains the misspelled word "setrings" instead of the proper "settings".

        Issue Links

          Activity

          Vincent Siveton added a comment -

          Fixed in r726434

          Patrick Crocker added a comment -

          The namespace misspelling has been corrected, however, the correction was performed in all caps:

          <settings xmlns="http://maven.apache.org/settings/1.0.0" 
                    xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
                    xsi:schemaLocation="http://maven.apache.org/SETTINGS/1.0.0 http://maven.apache.org/xsd/settings-1.0.0.xsd">
          

          The namespace in xsi:schemaLocation contains the all uppercase word "SETTINGS" instead of the proper "settings".

          John Casey added a comment -

          will revisit

          Herve Boutemy added a comment -

          changed xmlns to uppercase SETTINGS, to have consistent xmlns, xsi:schemaLocation and xsd's target namespace

          John Casey added a comment -

          will re-close with Not a Bug, since this was the original state of things.

          John Casey added a comment -

          sorry, my mistake...didn't realize this was reopened when I first saw it.


            People

            • Assignee:
              Vincent Siveton
              Reporter:
              Patrick Crocker
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: