Maven 2 & 3
  1. Maven 2 & 3
  2. MNG-3650

[regression] error reporting can not properly report a missing extension artifact

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 3.0-alpha-1
    • Fix Version/s: 3.0
    • Component/s: Errors
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      2

      Description

      note the following log - without -X, you wouldn't know that the problem was that the extension was not found

      1. error-reporting.txt
        19 kB
        Brett Porter
      2. pom.xml
        0.8 kB
        Brett Porter

        Activity

        Jason van Zyl added a comment -

        I cannot actually tell what you ran to get this, or what the POM looks like to test it.

        Brett Porter added a comment -

        see attached POM.

        In 2.0.9:

        [INFO] Error retrieving previous build number for artifact 'test:MNG-3650:jar': repository metadata for: 'snapshot test:MNG-3650:1.0-SNAPSHOT' could not be retrieved from repository: releases due to an error: Unsupported Protocol: 'foo': Cannot find wagon which supports the requested protocol: foo
        

        Not great, but the error is there at the end.

        In 3.0-SNAPSHOT:

        Internal error in the plugin manager executing goal 'org.apache.maven.plugins:maven-deploy-plugin:2.3:deploy': Mojo execution failed.
        

          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Brett Porter
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: