Maven
  1. Maven
  2. MNG-3376

plugin repositories are not checked when looking for snapshot plugin.

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 3.0
    • Fix Version/s: None
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Building current mevenide trunk with clean repository (https://svn.codehaus.org/mevenide/trunk/mevenide2)

      the root project defines <pluginManagement> section with nbm-maven-plugin in 2.7-SNAPSHOT version. at the same time it defines pluginRepository pointing to codehaus snapshots. The plugin is used by child projects.

      with 2.0.7 it builds fine.
      with current 2.1, the build fails because the 2.7-SNAPSHOT version is missing.

      attached is the content of the nbm-maven-plugin folder in local repository.

        Issue Links

          Activity

          Stephen Connolly added a comment - - edited

          Sounds like MNG-2994


            People

            • Assignee:
              Milos Kleint
              Reporter:
              Milos Kleint
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: