Maven
  1. Maven
  2. MNG-3213

Please update to plexus-utils 1.4.3 or later for PLXUTILS-36

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.8
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Please update to plexus-utils 1.4.3 or later to get the fix for PLXUTILS-36.

      This is a fairly minor bug, but the failure mode is extremely puzzling and quite difficult to debug if you have not seen it before.

      The problem is that, if an envvar with a single-character name is defined, then plexus-utils will mangle another envvar at random (depending on the random sort order of the environment block). For three developers in my office, it has impacted the SSH_AUTH_SOCK envvar, causing Subversion operations and Maven scpexe deployments to fail with mysterious-seeming authentication failures.

        Activity

        Vincent Siveton added a comment -

        Already fixed in mvn 2.0.8 with plexus-utils:1.4.6
        If a given maven project doesn't use it yet, please open another issue for the given project.


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            Max Bowsher
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: