Maven
  1. Maven
  2. MNG-3207

Order of repositories for download should be inverted if Archiva is used.

    Details

    • Type: Wish Wish
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.8
    • Component/s: Bootstrap & Build
    • Labels:
      None
    • Number of attachments :
      0

      Description

      Preconditions:

      1. Remoterepositories like central, codehaus, etc. are accessed over Archiva (configured via a mirror for central in the settings.xml).
      2. Direct internet access is disabled, HTTP Proxies for maven are not configured

      Maven can only access remote repositories over archiva. There are plugins which have a <repositories> section in there pom, like the jspc-maven-plugin. If artifacts are missing, then maven tries to download the missing artifacts from repositories defined in the plugins pom first. This fails after a long timeout and then maven tries to download the artifact from central which is mirrored by archiva.

      The problem is that the timeout is very long and cannot be configured. In my case a build can take more than two hours for a fresh installation.

      It would be great if the order of repositories is inverted if a mirror is configured in the settings.xml. Or if you can set the order of repositories on the command line. Or if it is possible to set the connection timeouts.

        Activity

        Mathias Arens added a comment -

        The problem does not occur with current maven 2.0.8-SNAPSHOT version if I define a <pluginRepository> pointing to archiva. But it does not always help in maven 2.0.7.

        Thus this issue can be closed.

        Mathias Arens added a comment -

        This problem does not occur with the current maven-2.0.8-SNAPSHOT version. But I had to add a <pluginRepository> section in the super pom.xml pointing to the archiva repository.


          People

          • Assignee:
            Unassigned
            Reporter:
            Mathias Arens
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: