Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.9
    • Component/s: Dependencies
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I have two sun jars defined as system dependencies ...

      <!-- AMSDK System Dependencies -->
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amclientsdk</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>$

      {pom.basedir}/amsdk/1amclientsdk.jar</systemPath>
      </dependency>
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amservices</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>${pom.basedir}

      /amsdk/am_services.jar</systemPath>
      </dependency>
      <dependency>
      <groupId>sun.amsdk</groupId>
      <artifactId>amconfig</artifactId>
      <version>2005q4</version>
      <scope>system</scope>
      <systemPath>$

      {pom.basedir}/amsdk</systemPath>
      </dependency>
      <!-- / AMSDK System Dependencies -->

      The reason for the last on is that the sun stuff demands a file called 'AMConfig.properties' file which is actually in the ${pom.basedir}

      /amsdk dir.

      It is absolutely crucial that 1amclientsdk.jar is in the classpath before am_services.jar as they define identical classes but the 1amclientsdk.jar versions are the ones I need (the 1 prefix is an attempt to force it to load early).

      9 times out of 10, the 1amclientsdk.jar is not before the am_services.jar. I have confirmed this using the -X option.

        Issue Links

          Activity

          Herve Boutemy added a comment -

          duplicate of MNG-1412
          BTW, fixed in 2.0.9-SNAPSHOT...


            People

            • Assignee:
              Herve Boutemy
              Reporter:
              Luke Daley
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: