Maven
  1. Maven
  2. MNG-3070

${x} properties no longer expanded in </version> tag after 2.0.3

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: 2.0.7
    • Fix Version/s: 2.0.10, 2.1.0-M1
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      0

      Description

      I was experimenting with maven using killer-app sample (http://www.sonatype.com/book/examples/book-killerapp.zip) from Sonatipe book (http://www.sonatype.com/book/index.html) and immediately hit a show stopper.
      Maven 2.0.3 is able to build the sample out of the box, but any later version up to 2.0.7 chokes telling that it's not able to find the parent project:

      C:\home\prjHome\mavenTest\killerapp>mvn help:effective-pom
      [INFO] Scanning for projects...
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] Failed to resolve artifact.

      GroupId: com.training.killerapp
      ArtifactId: killerapp
      Version: 1.0-SNAPSHOT

      Reason: Unable to download the artifact from any repository

      com.training.killerapp:killerapp:pom:1.0-SNAPSHOT

      from the specified remote repositories:
      central (http://repo1.maven.org/maven2)

      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      org.apache.maven.reactor.MavenExecutionException: Cannot find parent: com.training.killerapp:killerapp for project: null:killerapp-model:jar:null for project null:killerapp-model:jar:null
      at org.apache.maven.DefaultMaven.getProjects(DefaultMaven.java:378)
      at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:290)
      at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:125)
      at org.apache.maven.cli.MavenCli.main(MavenCli.java:280)
      at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      at java.lang.reflect.Method.invoke(Method.java:585)
      at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      at org.codehaus.classworlds.Launcher.main(Launcher.java:375)

      All the problems looks to be caused by the fact that the root POM has the following construct (that should be perfectly legal) in it:
      <version>$

      {killerappVersion}

      </version>

      <properties>
      <killerappVersion>1.0-SNAPSHOT</killerappVersion>
      </properties>

      If i substitute the version tag in the root POM with the following everything works with all versions.
      <version>1.0-SNAPSHOT</version>

      I was not able to find anywhere in the doc that $

      {x}

      substitution is no longer legal in </version> tag, so i think this is a regression from 2.0.3.

      Btw, all the test were done with clean local repository.

        Issue Links

          Activity

          Brett Porter made changes -
          Field Original Value New Value
          Fix Version/s 2.0.x [ 13141 ]
          Wojtek made changes -
          Link This issue is related to MNG-624 [ MNG-624 ]
          Wojtek added a comment -

          If MNG-624 was resolved, this one could be closed.

          brianfox brianfox added a comment -

          will need to verify, even maven uses properties in versions.

          brianfox brianfox made changes -
          Affects Version/s 2.0.7 [ 13138 ]
          Affects Version/s 2.0.9 [ 13801 ]
          brianfox brianfox made changes -
          Fix Version/s 2.0.x [ 13141 ]
          Affects Version/s 2.0.9 [ 13801 ]
          Fix Version/s 2.0.10 [ 14112 ]
          Affects Version/s 2.0.7 [ 13138 ]
          brianfox brianfox made changes -
          Link This issue relates to MNG-3535 [ MNG-3535 ]
          brianfox brianfox made changes -
          Link This issue relates to MNG-3536 [ MNG-3536 ]
          brianfox brianfox made changes -
          Link This issue relates to MNG-2562 [ MNG-2562 ]
          John Casey added a comment -

          The zip you reference in this description no longer exists, and there isn't enough information in this bug report to reproduce the problem. If you have a failing test case that you can attach, please don't hesitate to reopen this issue.

          John Casey made changes -
          Assignee John Casey [ jdcasey ]
          Status Open [ 1 ] Closed [ 6 ]
          Resolution Incomplete [ 4 ]
          John Casey added a comment -

          Adding fix-for for both 2.0.10 and 2.1.0-M1, since 2.1.0-M1 will actually be released first and may not incorporate all of the eventual issue fixes released in 2.0.10.

          John Casey made changes -
          Fix Version/s 2.1.0-M1 [ 14503 ]

            People

            • Assignee:
              John Casey
              Reporter:
              Gabriele Garuglieri
            • Votes:
              15 Vote for this issue
              Watchers:
              13 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: