Maven
  1. Maven
  2. MNG-2974

Unable to resolve & download snapshot versions from CLI

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0, 2.0.1, 2.0.2, 2.0.3, 2.0.4, 2.0.5, 2.0.6
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      When I try to use a snapshot released version of a plugin on the command line interface maven doesn't resolve these and download them from registered the plugin repositories. When using non snapshot versions it is not a problem to resolve and download them. When I add the plugin (a snapshot version) to a POM and run it it does download it. So the problem does not lie with the repo which is registered in the settings.xml in a profile which is active. The problem just seems to lie with the resolving and dowloading part of the process. Cause after the snapshot plugin is download using the POM way it does find the plugin when running it from the CLI.

      I first discovered this bug when trying to use the Maven install plugin. Here are commands used in the process. Reproding this way of use I got the same result when requesting other snapshot version of plugins that were not in the repository.

      Command used to load snapshot version from the CLI (this gives the error you find below)
      mvn org.apache.maven.plugins:maven-install-plugin:2.2-SNAPSHOT:install-file (... + correct plugin params )

      Command used to load a specific released version from the CLI
      mvn org.apache.maven.plugins:maven-install-plugin:2.1:install-file (... + correct plugin params )

      Command used to load a the top released version from the CLI
      mvn org.apache.maven.plugins:maven-install-plugin:install-file (... + correct plugin params )

      Settings.xml File

      <profile>
        <id>apachesnapshots</id>
        <pluginRepositories>
          <pluginRepository>
            <id>ddddd</id>
            <url>http://people.apache.org/repo/m2-snapshot-repository/</url>
            <releases>
              <enabled>false</enabled>
            </releases>
            <snapshots>
              <enabled>true</enabled>
              <updatePolicy>allways</updatePolicy>
              <checksumPolicy>ignore</checksumPolicy>
            </snapshots>
          </pluginRepository>
        </pluginRepositories>
      </profile>

      Hope I gave you enough information to fix this error. It's not major but does hinder me at this point cause now I have to manually place this plugin in everyone of my developers local repo.

        Issue Links

          Activity

            People

            • Assignee:
              Brett Porter
              Reporter:
              Yves Van Steen
            • Votes:
              4 Vote for this issue
              Watchers:
              7 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: