Maven
  1. Maven
  2. MNG-2906

version ranges don't work after a day has passed

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      2

      Description

      dependency A has a range dependency on B
      my project has a dependency on A (not directly on B)
      I build my project with a fresh clean repo (i.e. rm -rf ~/.m2/repository)
      B's latest is downloaded as expected
      the next morning I rebuild my project and I get error messages that no suitable version can be found;

      No versions are present in the repository for the artifact with a range [1.02b,) com.lowagie:itext-null.jar

      the particulars are jfreereports depending on [1.02b,) of lowagie.

      1. example.tar.gz
        1 kB
        Paul Smith
      2. example.X.output.txt
        15 kB
        Paul Smith

        Issue Links

          Activity

          Hide
          Paul Smith added a comment -

          If I manually 'mvn install:install-file' commons-collections 2.1 into my local repository (which is the minimum in the specified range), it then works, but only because I already have the other version ranged dependencies (such as commons-digester) already installed. I have verified this on multiple computers in the same office. If one computer does not have the specified minimum version as part of a dependency, even if they have later versions, this project fails.

          This is extremely painful.

          Show
          Paul Smith added a comment - If I manually 'mvn install:install-file' commons-collections 2.1 into my local repository (which is the minimum in the specified range), it then works, but only because I already have the other version ranged dependencies (such as commons-digester) already installed. I have verified this on multiple computers in the same office. If one computer does not have the specified minimum version as part of a dependency, even if they have later versions, this project fails. This is extremely painful.
          Hide
          Paul Smith added a comment -

          This could be a dupe of MNG-2742

          Show
          Paul Smith added a comment - This could be a dupe of MNG-2742
          Hide
          Maria Odea Ching added a comment -

          This has been mentioned a lot of times in the mailing list as well, so will leave this is 2.1..

          Show
          Maria Odea Ching added a comment - This has been mentioned a lot of times in the mailing list as well, so will leave this is 2.1..
          Show
          Jason van Zyl added a comment - Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014
          Hide
          Jason van Zyl added a comment -

          Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

          Show
          Jason van Zyl added a comment - Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.

            People

            • Assignee:
              Unassigned
              Reporter:
              Bill Dudney
            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: