Maven
  1. Maven
  2. MNG-2906

version ranges don't work after a day has passed

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Incomplete
    • Affects Version/s: None
    • Fix Version/s: None
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      2

      Description

      dependency A has a range dependency on B
      my project has a dependency on A (not directly on B)
      I build my project with a fresh clean repo (i.e. rm -rf ~/.m2/repository)
      B's latest is downloaded as expected
      the next morning I rebuild my project and I get error messages that no suitable version can be found;

      No versions are present in the repository for the artifact with a range [1.02b,) com.lowagie:itext-null.jar

      the particulars are jfreereports depending on [1.02b,) of lowagie.

      1. example.tar.gz
        1 kB
        Paul Smith
      2. example.X.output.txt
        15 kB
        Paul Smith

        Issue Links

          Activity

          Lautaro Mazzitelli added a comment - - edited

          Something on this issue?

          Damon Jacobsen added a comment -

          I also have this issue now. I am using JasperReports with the same dependency of com.lowagie.itext [1.02b,)

          Damon Jacobsen added a comment -

          It appears I was getting this message due to my Maven proxy server being down. This is a realy bad message for what is going on however.

          Paul Smith added a comment -

          Here's a generated maven project using 2.0.6 that exhibits this sort of behaviour. It was simply created as follows:

          1) mvn archetype:create -DgroupId=com.foo -DartifactId=bar -Dversion=1.0-SNAPSHOT -Dpackaging=jar
          2) Edit pom.xml, add dependency to latest jasperreports distribution
          3) mvn clean package

          thud

          Paul-Smiths-Computer:/temp/bar paulsmith$ mvn clean package
          [INFO] Scanning for projects...
          [INFO] ----------------------------------------------------------------------------
          [INFO] Building bar
          [INFO] task-segment: [clean, package]
          [INFO] ----------------------------------------------------------------------------
          [INFO] [clean:clean]
          [INFO] Deleting directory /temp/bar/target
          [INFO] Deleting directory /temp/bar/target/classes
          [INFO] Deleting directory /temp/bar/target/test-classes
          [INFO] Deleting directory /temp/bar/target/site
          [INFO] [resources:resources]
          [INFO] Using default encoding to copy filtered resources.
          [INFO] ------------------------------------------------------------------------
          [ERROR] BUILD ERROR
          [INFO] ------------------------------------------------------------------------
          [INFO] Failed to resolve artifact.

          No versions are present in the repository for the artifact with a range [2.1,)
          commons-collections:commons-collections:jar:null

          from the specified remote repositories:
          central (http://repo1.maven.org/maven2)

          [INFO] ------------------------------------------------------------------------
          [INFO] For more information, run Maven with the -e switch
          [INFO] ------------------------------------------------------------------------
          [INFO] Total time: 1 second
          [INFO] Finished at: Thu Aug 23 17:46:27 EST 2007
          [INFO] Final Memory: 3M/6M
          [INFO] ------------------------------------------------------------------------

          ***********************************************************

          This is regardless of using Archiva or standard central repo usage.

          Paul Smith added a comment -

          Attached 'mvn -X clean compile' output.

          Paul Smith added a comment -

          If I manually 'mvn install:install-file' commons-collections 2.1 into my local repository (which is the minimum in the specified range), it then works, but only because I already have the other version ranged dependencies (such as commons-digester) already installed. I have verified this on multiple computers in the same office. If one computer does not have the specified minimum version as part of a dependency, even if they have later versions, this project fails.

          This is extremely painful.

          Paul Smith added a comment -

          This could be a dupe of MNG-2742

          Maria Odea Ching added a comment -

          This has been mentioned a lot of times in the mailing list as well, so will leave this is 2.1..

          Jason van Zyl added a comment -

          Please refer to https://cwiki.apache.org/confluence/display/MAVEN/The+Great+JIRA+Cleanup+of+2014 if you're wondering why this issue was closed out.


            People

            • Assignee:
              Unassigned
              Reporter:
              Bill Dudney
            • Votes:
              4 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: