Maven
  1. Maven
  2. MNG-2773

Plugin repositories are chekced for SNAPSHOTS on every run in the 2.0.5 candidate

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 2.0.5
    • Fix Version/s: 2.0.5
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      0

      Description

      Trussing the mvn process shows that Maven tries to connect to the plugin repository on every run, instead of the daily check.

      [16:38:50][tlaugstoel@sunw360:monitor-core]$ truss -t connect mvn -Dmaven.test.skip=true install
      [INFO] Scanning for projects...
      [INFO] ----------------------------------------------------------------------------
      [INFO] Building Unnamed - no.java.monitor:monitor-core:jar:1.0-SNAPSHOT
      [INFO]    task-segment: [install]
      [INFO] ----------------------------------------------------------------------------
      [INFO] artifact org.apache.maven.plugins:maven-resources-plugin: checking for updates from codehaus-snapshots
      /1:     connect(8, 0xFFBFBAF4, 16, SOV_DEFAULT)         = 0
      /1:     connect(7, 0xFFBFBD98, 16, SOV_DEFAULT)         = 0
      [INFO] artifact org.apache.maven.plugins:maven-compiler-plugin: checking for updates from codehaus-snapshots
      /1:     connect(7, 0xFFBFBD80, 16, SOV_DEFAULT)         = 0
      [INFO] artifact org.apache.maven.plugins:maven-surefire-plugin: checking for updates from codehaus-snapshots
      /1:     connect(9, 0xFFBFBD98, 16, SOV_DEFAULT)         = 0
      [INFO] artifact org.apache.maven.plugins:maven-jar-plugin: checking for updates from codehaus-snapshots
      /1:     connect(7, 0xFFBFBD80, 16, SOV_DEFAULT)         = 0
      [INFO] artifact org.apache.maven.plugins:maven-install-plugin: checking for updates from codehaus-snapshots
      [INFO] [plexus:descriptor {execution: default}]
      [INFO] [resources:resources]
      [INFO] Using default encoding to copy filtered resources.
      [WARNING] 
              Artifact junit:junit:jar:3.8.1:test retains local scope 'test' overriding broader scope 'compile'
              given by a dependency. If this is not intended, modify or remove the local scope.
      

        Issue Links

          Activity

          Jason van Zyl made changes -
          Field Original Value New Value
          Fix Version/s 2.0.5 [ 12294 ]
          Kenney Westerhof made changes -
          Assignee Kenney Westerhof [ kenneyw ]
          Kenney Westerhof made changes -
          Link This issue duplicates MNG-2712 [ MNG-2712 ]
          Kenney Westerhof made changes -
          Resolution Duplicate [ 3 ]
          Status Open [ 1 ] Closed [ 6 ]
          Brett Porter added a comment -

          is this definitely a dupe of MNG-2712? I'm worried it's a result of the change in MNG-1908

          Brett Porter made changes -
          Component/s Repositories [ 12034 ]

            People

            • Assignee:
              Kenney Westerhof
              Reporter:
              Trygve Laugstøl
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: