Maven
  1. Maven
  2. MNG-2289

Newer SNAPSHOT parents in the remote repository are ignored

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: 2.0.5
    • Fix Version/s: 2.0.7
    • Labels:
      None
    • Complexity:
      Intermediate
    • Testcase included:
      yes
    • Number of attachments :
      2

      Description

      If a POM inherits from another one in the repository with a SNAPSHOT version, it will only look into the local repository for it, but not in the remote repositories.
      E.g. if a POM has following parent:...
      <parent>
      <groupId>pom.maven</groupId>
      <artifactId>super</artifactId>
      <version>SNAPSHOT</version>
      </parent>
      ...

      it will not find a newer version of "pom.maven:super:SNAPSHOT" in a remote repository.

        Issue Links

          Activity

          Jason van Zyl added a comment -

          I will check with Kenney because I think this was fixed in trunk and I'll backport it if necessary.

          Jason van Zyl added a comment -

          Joerg, do you want to check this out:

          https://svn.apache.org/repos/asf/maven/core-integration-testing/trunk/core-integration-tests/src/test/resources/MNG-2289

          I tried to mimic your test and simplify it and it appears to be working. The new parent POM is used and the updated dependency is used.

          Patrick Schneider added a comment -

          When I run the IT that Jason just committed (https://svn.apache.org/repos/asf/maven/core-integration-testing/trunk/core-integration-tests/src/test/resources/MNG-2289/), I see commons-logging-1.0.2 pulled in after re-deployment of the parent SNAPSHOT, showing that the child does pick up the newer version. So, at least with this test, I'm not able to reproduce the problem.

          Patrick Schneider added a comment -

          I was using 2.0.6.

          Jason van Zyl added a comment -

          Patrick and I cannot not reproduce this Jorg, so we're going to mark can't reproduce. Unless you want to take a look at the IT we whipped up and see if you can.


            People

            • Assignee:
              Jason van Zyl
              Reporter:
              Jörg Schaible
            • Votes:
              19 Vote for this issue
              Watchers:
              21 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: