Maven
  1. Maven
  2. MNG-2124

Incorrect resolution of parent POM properties

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0.2
    • Fix Version/s: 2.0.3
    • Labels:
      None
    • Environment:
      Windows XP, JDK 1.4.2_11
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      Unzip maven-bug to current dir and cd to maven-bug/artifact.

      Now, Maven 2.0.1 handles things correctly (irrelevant output removed):

      [echo] Parent: parentartifact, project: artifact

      But Maven 2.0.2 has a bug:

      [echo] Parent: artifact, project: artifact

        Issue Links

          Activity

          Brett Porter added a comment -

          promoting if it is a regression

          Mauro Talevi added a comment -

          Don't know if related to this bug, but there seems to be another regression issue with 2.0.3-SNAPSHOT:

          If the parent pom (SNAPSHOT version) is not found in remote repo mvn chokes and does not generate it as it should when running from top-level.

          This behaviour does not appear in 2.0.2 so is definitely a regression.

          Mauro Talevi added a comment -

          Created MNG-2130 to track the inability to re-created parent POM - as seems sufficient different in scope.

          John Casey added a comment -

          this seems to have to do with trimming the root token from an expression before evaluating it, even though that's already been done...

          John Casey added a comment -

          see it0088 and it0100 (it0100 has the test case provided in this report, slightly modified to fit the integration testing framework).

          Kjetil Ødegaard added a comment -

          Great! Looks like this fixed my problem.


            People

            • Assignee:
              John Casey
              Reporter:
              Kjetil Ødegaard
            • Votes:
              1 Vote for this issue
              Watchers:
              1 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: