Maven
  1. Maven
  2. MNG-1911

Building plugins with extensions in a reactor fails

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Won't Fix
    • Affects Version/s: 2.0.1
    • Fix Version/s: None
    • Component/s: Plugins and Lifecycle
    • Labels:
      None
    • Complexity:
      Intermediate
    • Number of attachments :
      1

      Description

      I have the following in my main pom

      <build>
       <pluginManagement>
        <plugins>
         <plugin>
          <groupId>org.apache.servicemix.plugins</groupId>
          <artifactId>maven2-jbi-plugin</artifactId>
          <version>1.0-SNAPSHOT</version>
          <extensions>true</extensions>
         </plugin>
        </plugins>
       </pluginManagement>
      </build>
      

      If i try to add it to the modules, the first time, maven complains that it can not download the plugin.
      If i remove the <extensions> tag, all works, but i need it

        Issue Links

          Activity

          Jason van Zyl added a comment -

          Anyone else thought about this from the discussion on the mailing list? I would like to close this as won't fix.

          Jason van Zyl added a comment -

          Trying to build plugins that have extensions that are to be used in the same build is just a complication in the core we're not going to accommodate. This is in part because extensions are ill defined and can be used for many things but trying to make extensions work generally where transport is provided is very difficult. If, in the future, we define different types of extensions some of these can likely be accommodated.

          Paul Benedict added a comment -

          Removed specified fixed version.

          Vincent Massol added a comment -

          Very disappointed that issues reported by users are just discarded without any plan to fix them This is not the first one I see like this. Closing invalid issues is ok but closing valid issues with a won't fix is not a good signal sent to users... Especially when no workaround is provided...

          Arnaud Heritier added a comment -

          The only existing workaround is to extract your extension (or the plugin defining it) in another independent project (which I agree, is often overkill).
          I don't know if Jason van Zyl and others who worked on the core recently have an idea how to fix it but the root cause of the problem is that an extension can extend an existing lifecycle or add a new one and thus Maven may require it to read poms).


            People

            • Assignee:
              Jason van Zyl
              Reporter:
              Guillaume Nodet
            • Votes:
              10 Vote for this issue
              Watchers:
              16 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: