Mojo's NetBeans Module Maven Plugin
  1. Mojo's NetBeans Module Maven Plugin
  2. MNBMODULE-85

Output logs are not printed to output window when running netbeans application

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Duplicate
    • Affects Version/s: 3.2
    • Fix Version/s: None
    • Labels:
      None
    • Environment:
      Windows XP sp3
      SUN (ORACLE) JDK 1.6.0_20
      Apache Maven 2.2.1
    • Number of attachments :
      1

      Description

      Output logs are not printed to output window when running netbeans application and using nbm-maven-plugin 3.2
      When running nbm-maven-plugin 3.1 all is fine

      Using netbeans 6.8 or 6.9 create a new maven netbeans platform application.
      Just run the application and check that no logs are printed after the lines :
      [nbm:run]
      Executing: cmd.exe /X /C ""My Documents\NetBeansProjects\mavenproject1\application\target\userdir" -J-Dnetbeans.logger.console=true -J-ea --branding foo"

      Go to main pom.xml and change in the pluginManagement section the version of the nbm-maven-plugin to 3.1 instead of 3.2 and you will see all the output logs again.
      The problem is only with plugin 3.2

        Issue Links

          Activity

          Milos Kleint added a comment -

          this could be caused by the upgrade of plexus-utils dependency from 1.5.4 to 1.5.15. nothing relevant seems to have changed in the goal itself.


            People

            • Assignee:
              Milos Kleint
              Reporter:
              Christian Lebaudy
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: