Maven Linkcheck Plugin
  1. Maven Linkcheck Plugin
  2. MLINKCHECK-9

The necessary images are not included in the generated site, if you use a custom skin

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 1.0.1
    • Fix Version/s: 1.1
    • Labels:
      None
    • Number of attachments :
      0

      Description

      The plugin does not copy the resources (images) that it uses in the generated report. The icons, like images/icon_success_sml.gif, are not copied to the target site. If the skin being used does not have these icons in it, the report will not have any icons.

      I remember that we had this problem for the Changes Plugin before. See http://svn.apache.org/viewvc?view=revision&revision=422229 for a possible solution.

        Activity

        Dennis Lundberg made changes -
        Field Original Value New Value
        Description The plugin does not copy the resources (images) that it uses in the generated report. The icons, like images/icon_success_sml.gif, are not copied to the target site. If the skin being used does not have these icons in it, the report will not have any icons.

        I remember that we had this problem for the Checkstyle Plugin before. There should be a solution there that we can use.
        The plugin does not copy the resources (images) that it uses in the generated report. The icons, like images/icon_success_sml.gif, are not copied to the target site. If the skin being used does not have these icons in it, the report will not have any icons.

        I remember that we had this problem for the Changes Plugin before. See http://svn.apache.org/viewvc?view=revision&revision=422229 for a possible solution.
        Hide
        Lukas Theussl added a comment -

        Fixed in r1021298

        Show
        Lukas Theussl added a comment - Fixed in r1021298
        Lukas Theussl made changes -
        Status Open [ 1 ] Closed [ 6 ]
        Assignee Lukas Theussl [ lukas ]
        Fix Version/s 1.1 [ 16748 ]
        Resolution Fixed [ 1 ]
        Hide
        Andreas Horst added a comment -

        I know this issue is pretty old but I'm observing this with the maven-project-info-reports-plugin 2.7. I use a custom skin and all image resources except those included in the custom skin are missing (even things like the icon for external links).

        What was the exact issue or workaround for this?

        Show
        Andreas Horst added a comment - I know this issue is pretty old but I'm observing this with the maven-project-info-reports-plugin 2.7. I use a custom skin and all image resources except those included in the custom skin are missing (even things like the icon for external links). What was the exact issue or workaround for this?
        Hide
        Andreas Horst added a comment -

        NVM, I found MSITE-97 and apparently it's the responsibility of the skin developer to know all "default" images/icons to include in his custom skin...

        Show
        Andreas Horst added a comment - NVM, I found MSITE-97 and apparently it's the responsibility of the skin developer to know all "default" images/icons to include in his custom skin...

          People

          • Assignee:
            Lukas Theussl
            Reporter:
            Dennis Lundberg
          • Votes:
            0 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: