Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-62

javadoc:javadoc needs access to generated sources

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.0
    • Fix Version/s: 2.1
    • Labels:
      None
    • Number of attachments :
      2

      Description

      currently, maven-model will not generate apidocs by simply calling javadoc:javadoc. This is because maven-model's sources are generated, and the javadoc report doesn't ensure that the 'generate-sources' phase is called.

      However, when I changed the report to have:

      @execute phase="generate-sources"

      It still doesn't work. I suspect this may be because it's forking a new lifecycle and cloning the project to call generate-sources, which means the report doesn't use the right project instance to create the report. However, I've been unable to inject $

      {executedProject}

      as a parameter; it fails the build, saying I need to supply that parameter on the command line.

      I haven't committed any code changes to this report, since I don't currently have time to debug it properly, and I obviously haven't solved the problem.

      1. MJAVADOC-62.diff
        9 kB
        Brett Porter
      2. MJAVADOC-62.diff
        1 kB
        Brett Porter

        Activity

        John Casey added a comment -

        steps to reproduce:

        1. go into maven-model
        2. `mvn clean site`
        3. open $

        {basedir}

        target/site/apidocs/index.html in your browser.

        Jesse McConnell added a comment -

        mvn generate-sources javadoc:javadoc works

        working on the rest of it

        Brett Porter added a comment -

        seeing now it doesn't work in the site plugin, even though the phase is executed

        Vincent Siveton added a comment -

        Already fixed (with MJAVADOC-61)
        Tested with maven-model and rev 441291 for the plugin
        #mvn clean javadoc:javadoc
        #mvn clean site


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            John Casey
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: