Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-340

Javadoc generation with includeDependencySources=true crashes when any of those dependencies have scope=provided dependencies

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Cannot Reproduce
    • Affects Version/s: None
    • Fix Version/s: 2.9
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Using this configuration in jbpm-distribution:

      
                  <configuration>
                    <includeDependencySources>true</includeDependencySources>
                    <dependencySourceIncludes>
                      <dependencySourceInclude>org.jbpm:*</dependencySourceInclude>
                    </dependencySourceIncludes>
                  </configuration>
      

      I got this:

      [INFO] ------------------------------------------------------------------------
      [INFO] BUILD FAILURE
      [INFO] ------------------------------------------------------------------------
      [INFO] Total time: 13.620s
      [INFO] Finished at: Tue Jan 17 15:05:07 CET 2012
      [INFO] Final Memory: 17M/441M
      [INFO] ------------------------------------------------------------------------
      [ERROR] Failed to execute goal org.apache.maven.plugins:maven-javadoc-plugin:2.8:javadoc (javadoc-javadoc) on project jbpm-distribution: An error has occurred in JavaDocs report generation:
      [ERROR] Exit code: 1 - /home/gdesmet/projects/jboss/droolsjbpm/jbpm/jbpm-distribution/target/distro-javadoc-sources/jbpm-flow-5.3.0-SNAPSHOT-sources/org/jbpm/osgi/flow/core/Activator.java:26: package org.osgi.framework does not exist
      [ERROR] import org.osgi.framework.BundleActivator;
      

      Workaround: Explicitly add the provided scope dependencies one by one

          <dependency>
            <groupId>org.apache.felix</groupId>
            <artifactId>org.osgi.core</artifactId>
            <scope>provided</scope>
          </dependency>
          <dependency>
            <groupId>org.apache.felix</groupId>
            <artifactId>org.osgi.compendium</artifactId>
            <scope>provided</scope>
          </dependency>
      

      (and if you're doing this in an assembly, make sure your zips don't get to big or to small)

        Issue Links

          Activity

          Benson Margulies added a comment -

          I cannot reproduce this. I adapted an integration test to follow the recipe, and it worked fine. So unless you can attach a complete failing test case, this will be closed.

          Benson Margulies added a comment -

          Please reopen if you attach a test case.

          Geoffrey De Smet added a comment -

          Which version did you test? Please set it as fix version.

          Benson Margulies added a comment -

          I tested the trunk, which will be 2.9, and I set the fix version to 2.9 as a result just now.

          Gert Vanderseypen added a comment -

          I have the same problem; see my test project in attachment
          You can see in the logs that it crashes because the lombok javadoc resources are not found.


            People

            • Assignee:
              Benson Margulies
              Reporter:
              Geoffrey De Smet
            • Votes:
              0 Vote for this issue
              Watchers:
              4 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: