Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-275

Creation of Javadoc attachments fails in multi-module project where modules have never been installed/deployed

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Critical Critical
    • Resolution: Fixed
    • Affects Version/s: 2.6.1
    • Fix Version/s: 2.8
    • Labels:
      None
    • Testcase included:
      yes
    • Number of attachments :
      1

      Description

      Running the commands

      mvn clean
      mvn verify
      

      will fail on the attached demo project with

      [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6.1:javadoc'
        has not be previously called for the project: 'org.apache.maven.its.javadoc:mod-b:jar:0.1'.
        Trying to invoke it...
      [ERROR] MavenInvocationException: Error when invoking Maven, consult the invoker log file:
        M:\MJAVADOC\mod-a\target\invoker\maven-javadoc-plugin625147587.txt
      [INFO] ------------------------------------------------------------------------
      [ERROR] BUILD ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] MavenReportException: Error while creating archive:
        Error when invoking Maven, consult the invoker log file: 
        M:\MJAVADOC\mod-a\target\invoker\maven-javadoc-plugin625147587.txt
      

      The command mvn clean verify as usually used during releases will also fail, but starts working after repeated invocations.

        Issue Links

          Activity

          Dinesh Mehta added a comment -

          I still see this error with v2.7. What are the configurations to run the plugin in aggreagte mode for a multi-module project?

          Yegor Bugayenko added a comment -

          The problem is still not fixed. Why the issue is closed?

          Dan Tran added a comment -

          reopen since javadoc plugin 2.7 still see the same issue

          John Casey added a comment -

          what about 2.8? can we close this issue now that MJAVADOC-284 is closed? I haven't seen it, unless you're talking about the case where the javadoc plugin forks a new build in order to produce javadocs for dependencies...for which there is a flag to skip that, and I'm assuming MJAVADOC-284 has fixed in a more permanent way.

          Herve Boutemy added a comment -

          yes, with MJAVADOC-284 fixed, this issue is a duplicate IMHO


            People

            • Assignee:
              John Casey
              Reporter:
              Benjamin Bentmann
            • Votes:
              12 Vote for this issue
              Watchers:
              19 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: