Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-246

ExceptionInInitializerError with maven-site-plugin:2.1-SNAPSHOT and mvn > 2.1

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Blocker Blocker
    • Resolution: Fixed
    • Affects Version/s: 2.6
    • Fix Version/s: 2.6.1
    • Labels:
      None
    • Environment:
      Hudson or command-line
      Maven 2.1.0 or 2.2.0
      JDK 1.6 or JDK 1.7
      maven-site-plugin:2.1-SNAPSHOT
      OpenSolaris
    • Number of attachments :
      0

      Description

      This bug only happens if I have maven-javadoc-plugin enabled. If I comment it out site generation works. The POM is not specifying a particular version so I am not sure which one it is using.

      These bugs seem to report the same problem against other plugins:
      http://jira.codehaus.org/browse/MOJO-1118
      http://jira.codehaus.org/browse/MOJO-1101

      Based on the error message, I checked the repository after successfully building without JavaDoc and it shows these versions of commons-logging were used:
      1.0
      1.0.3
      1.0.4
      1.1

      The only SNAPSHOT dependency is 2.1-SNAPSHOT of the maven-site-plugin (to get around site generation bugs). I am using the -U during building.

      # mvn site
      ...
      [INFO] Generating "JavaDocs" report.
      [FATAL ERROR] org.apache.maven.plugins.site.SiteMojo#execute() caused a linkage error (java.lang.ExceptionInInitializerError) and may be out-of-date. Check the realms:
      [FATAL ERROR] Plugin realm = app0.child-container[org.apache.maven.plugins:maven-site-plugin:2.1-SNAPSHOT]
      urls[0] = file:/home/hudson/.m2/repository/org/apache/maven/plugins/maven-site-plugin/2.1-SNAPSHOT/maven-site-plugin-2.1-SNAPSHOT.jar
      urls[1] = file:/home/hudson/.m2/repository/org/codehaus/plexus/plexus-utils/1.5.1/plexus-utils-1.5.1.jar
      urls[2] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-module-xhtml/1.1.2-SNAPSHOT/doxia-module-xhtml-1.1.2-SNAPSHOT.jar
      urls[3] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-core/1.1.2-SNAPSHOT/doxia-core-1.1.2-SNAPSHOT.jar
      urls[4] = file:/home/hudson/.m2/repository/xerces/xercesImpl/2.8.1/xercesImpl-2.8.1.jar
      urls[5] = file:/home/hudson/.m2/repository/xml-apis/xml-apis/1.3.03/xml-apis-1.3.03.jar
      urls[6] = file:/home/hudson/.m2/repository/commons-lang/commons-lang/2.4/commons-lang-2.4.jar
      urls[7] = file:/home/hudson/.m2/repository/commons-httpclient/commons-httpclient/3.1/commons-httpclient-3.1.jar
      urls[8] = file:/home/hudson/.m2/repository/commons-logging/commons-logging/1.0.4/commons-logging-1.0.4.jar
      urls[9] = file:/home/hudson/.m2/repository/commons-codec/commons-codec/1.2/commons-codec-1.2.jar
      urls[10] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-module-apt/1.1.2-SNAPSHOT/doxia-module-apt-1.1.2-SNAPSHOT.jar
      urls[11] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-module-xdoc/1.1.2-SNAPSHOT/doxia-module-xdoc-1.1.2-SNAPSHOT.jar
      urls[12] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-module-fml/1.1.2-SNAPSHOT/doxia-module-fml-1.1.2-SNAPSHOT.jar
      urls[13] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-decoration-model/1.1.2-SNAPSHOT/doxia-decoration-model-1.1.2-SNAPSHOT.jar
      urls[14] = file:/home/hudson/.m2/repository/org/apache/maven/doxia/doxia-site-renderer/1.1.2-SNAPSHOT/doxia-site-renderer-1.1.2-SNAPSHOT.jar
      urls[15] = file:/home/hudson/.m2/repository/org/codehaus/plexus/plexus-i18n/1.0-beta-7/plexus-i18n-1.0-beta-7.jar
      urls[16] = file:/home/hudson/.m2/repository/org/codehaus/plexus/plexus-velocity/1.1.7/plexus-velocity-1.1.7.jar
      urls[17] = file:/home/hudson/.m2/repository/org/apache/velocity/velocity/1.5/velocity-1.5.jar
      urls[18] = file:/home/hudson/.m2/repository/commons-collections/commons-collections/3.2/commons-collections-3.2.jar
      urls[19] = file:/home/hudson/.m2/repository/oro/oro/2.0.8/oro-2.0.8.jar
      urls[20] = file:/home/hudson/.m2/repository/org/apache/maven/shared/maven-doxia-tools/1.1-SNAPSHOT/maven-doxia-tools-1.1-SNAPSHOT.jar
      urls[21] = file:/home/hudson/.m2/repository/commons-io/commons-io/1.4/commons-io-1.4.jar
      urls[22] = file:/home/hudson/.m2/repository/org/codehaus/plexus/plexus-archiver/1.0-alpha-7/plexus-archiver-1.0-alpha-7.jar
      urls[23] = file:/home/hudson/.m2/repository/org/mortbay/jetty/jetty/6.1.5/jetty-6.1.5.jar
      urls[24] = file:/home/hudson/.m2/repository/org/mortbay/jetty/jetty-util/6.1.5/jetty-util-6.1.5.jar
      urls[25] = file:/home/hudson/.m2/repository/org/mortbay/jetty/servlet-api-2.5/6.1.5/servlet-api-2.5-6.1.5.jar
      [FATAL ERROR] Container realm = plexus.core
      urls[0] = file:/opt/apache-maven-2.1.0/lib/maven-2.1.0-uber.jar
      [INFO] ------------------------------------------------------------------------
      [ERROR] FATAL ERROR
      [INFO] ------------------------------------------------------------------------
      [INFO] null
      Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.
      [INFO] ------------------------------------------------------------------------
      [INFO] Trace
      java.lang.ExceptionInInitializerError
      	at org.apache.maven.plugin.javadoc.JavadocUtil.fetchURL(JavadocUtil.java:730)
      	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.isValidJavadocLink(AbstractJavadocMojo.java:4680)
      	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.addLinkArguments(AbstractJavadocMojo.java:3229)
      	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.addStandardDocletOptions(AbstractJavadocMojo.java:3885)
      	at org.apache.maven.plugin.javadoc.AbstractJavadocMojo.executeReport(AbstractJavadocMojo.java:1761)
      	at org.apache.maven.plugin.javadoc.JavadocReport.generate(JavadocReport.java:122)
      	at org.apache.maven.plugins.site.ReportDocumentRenderer.renderDocument(ReportDocumentRenderer.java:164)
      	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.renderModule(DefaultSiteRenderer.java:337)
      	at org.apache.maven.doxia.siterenderer.DefaultSiteRenderer.render(DefaultSiteRenderer.java:138)
      	at org.apache.maven.plugins.site.SiteMojo.renderLocale(SiteMojo.java:135)
      	at org.apache.maven.plugins.site.SiteMojo.execute(SiteMojo.java:102)
      	at org.apache.maven.plugin.DefaultPluginManager.executeMojo(DefaultPluginManager.java:483)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoals(DefaultLifecycleExecutor.java:678)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalWithLifecycle(DefaultLifecycleExecutor.java:540)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoal(DefaultLifecycleExecutor.java:519)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeGoalAndHandleFailures(DefaultLifecycleExecutor.java:371)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.executeTaskSegments(DefaultLifecycleExecutor.java:332)
      	at org.apache.maven.lifecycle.DefaultLifecycleExecutor.execute(DefaultLifecycleExecutor.java:181)
      	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:356)
      	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:137)
      	at org.apache.maven.cli.MavenCli.main(MavenCli.java:356)
      	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
      	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:39)
      	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:25)
      	at java.lang.reflect.Method.invoke(Method.java:597)
      	at org.codehaus.classworlds.Launcher.launchEnhanced(Launcher.java:315)
      	at org.codehaus.classworlds.Launcher.launch(Launcher.java:255)
      	at org.codehaus.classworlds.Launcher.mainWithExitCode(Launcher.java:430)
      	at org.codehaus.classworlds.Launcher.main(Launcher.java:375)
      Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: 
      org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, 
      which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 
      'org.apache.commons.logging.Log' visible, which is not allowed.) (Caused by org.apache.commons.logging.LogConfigurationException: 
      org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, 
      which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 
      'org.apache.commons.logging.Log' visible, which is not allowed.))
      	at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:543)
      	at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:235)
      	at org.apache.commons.logging.impl.LogFactoryImpl.getInstance(LogFactoryImpl.java:209)
      	at org.apache.commons.logging.LogFactory.getLog(LogFactory.java:351)
      	at org.apache.commons.httpclient.HttpClient.<clinit>(HttpClient.java:66)
      	... 29 more
      Caused by: org.apache.commons.logging.LogConfigurationException: org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have 
      more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed. (Caused by org.apache.commons.logging.LogConfigurationException: Invalid
       class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' visible, which is not allowed.)
      	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:397)
      	at org.apache.commons.logging.impl.LogFactoryImpl.newInstance(LogFactoryImpl.java:529)
      	... 33 more
      Caused by: org.apache.commons.logging.LogConfigurationException: Invalid class loader hierarchy.  You have more than one version of 'org.apache.commons.logging.Log' 
      visible, which is not allowed.
      	at org.apache.commons.logging.impl.LogFactoryImpl.getLogConstructor(LogFactoryImpl.java:385)
      	... 34 more
      [INFO] ------------------------------------------------------------------------
      
      

        Activity

        Vincent Siveton added a comment -

        confirmed

        Malachi de AElfweald added a comment -

        2.6-SNAPSHOT does appear to have fixed that issue; leaving behind a weird side effect:

        [INFO] Generating "JavaDocs" report.
        Aug 3, 2009 10:15:45 AM org.apache.commons.httpclient.HttpMethodBase processCookieHeaders
        WARNING: Cookie rejected: "$Version=0; JSESSIONID=50AF6CD52E5016EFA7D533AF6DD95394; $Path=/servlets". Illegal path attribute "/servlets". Path of origin: "/nonav/maven/apidocs/package-list"
        [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6-SNAPSHOT:javadoc' has not be previously called for the project: 'org.eoti.maven.skins:ljod:jar:2.3-SNAPSHOT'. Trying to invoke it...
        [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6-SNAPSHOT:javadoc' has not be previously called for the project: 'org.eoti:seshat:jar:2.3-SNAPSHOT'. Trying to invoke it...
        [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6-SNAPSHOT:javadoc' has not be previously called for the project: 'org.eoti:clotho:jar:2.3-SNAPSHOT'. Trying to invoke it...
        [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6-SNAPSHOT:javadoc' has not be previously called for the project: 'org.eoti:lachesis:jar:2.3-SNAPSHOT'. Trying to invoke it...
        [INFO] The goal 'org.apache.maven.plugins:maven-javadoc-plugin:2.6-SNAPSHOT:javadoc' has not be previously called for the project: 'org.eoti:atropos:jar:2.3-SNAPSHOT'. Trying to invoke it...
        Loading source files for package org.eoti.rei.cmp...

        Parolini Antonio added a comment -

        Same here. My workaround is to force version 2.5 of the maven-javadoc-plugin

        Malachi de AElfweald added a comment -

        I misspoke earlier. In addition to changing to 2.6-SNAPSHOT I had changed the maven-site-plugin version (and thus broke other parts of the site). Changing the maven-site-plugin back to 2.1-SNAPSHOT w/ javadoc at 2.6-SNAPSHOT I still get the error.

        Vincent Siveton added a comment -

        Fixed in r814574, snapshot deployed


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            Malachi de AElfweald
          • Votes:
            3 Vote for this issue
            Watchers:
            4 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: