Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-215

warning proxyHost' is deprecated since 2.4

    Details

    • Type: Bug Bug
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Fixed
    • Affects Version/s: 2.5
    • Fix Version/s: 2.6
    • Labels:
      None
    • Environment:
      mvn 2.0.9
      jdk 1.5
    • Number of attachments :
      0

      Description

      [WARNING] The Javadoc plugin parameter 'proxyHost' is deprecated since 2.4. Please configure an active proxy in your settings.xml.

      i dont define any proxyhost in the plugin-configuration and i have define a proxy in my settings.xml - whats the problem?

        Activity

        Hide
        Jochen Hinrichsen added a comment -

        Same problem, same environment.
        I could revert to 2.4 but 2.5 has this very nice project.build.sourceEncoding feature.
        Ok, it's WARNING, not ERROR, but for audit issues i prefer clean build logs.

        Show
        Jochen Hinrichsen added a comment - Same problem, same environment. I could revert to 2.4 but 2.5 has this very nice project.build.sourceEncoding feature. Ok, it's WARNING, not ERROR, but for audit issues i prefer clean build logs.
        Hide
        Benjamin Bentmann added a comment -

        Fixed in r734773, snapshot deployed.

        Show
        Benjamin Bentmann added a comment - Fixed in r734773 , snapshot deployed.
        Hide
        Jochen Hinrichsen added a comment -

        Tested against 2.5.1-SNAPSHOT, works.

        Thanks!

        Show
        Jochen Hinrichsen added a comment - Tested against 2.5.1-SNAPSHOT, works. Thanks!

          People

          • Assignee:
            Benjamin Bentmann
            Reporter:
            Andreas Höhmann
          • Votes:
            1 Vote for this issue
            Watchers:
            1 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: