Maven Javadoc Plugin
  1. Maven Javadoc Plugin
  2. MJAVADOC-126

Add the ability to load the stylesheet from a jar (resource)

    Details

    • Type: Wish Wish
    • Status: Closed Closed
    • Priority: Minor Minor
    • Resolution: Fixed
    • Affects Version/s: 2.2
    • Fix Version/s: 2.5
    • Labels:
      None
    • Number of attachments :
      4

      Description

      Currently, the stylesheetfile has to be given as a path on the filesystem, which makes sharing quite difficult.
      It would be nice to be able to retrieve it from a jar (like the checkstyle and the pmd plugins).

      1. 20080520-maven-javadoc-plugin-external-resources.patch
        21 kB
        Francois Fernandes
      2. 20080530-maven-javadoc-plugin-external-resources.patch
        8 kB
        Francois Fernandes

        Activity

        Francois Fernandes added a comment -

        I have the same problem. Attached to this Issue you'll find two files:

        Francois Fernandes added a comment -
        • updated the patch to meet the current trunk.
        • renamed the extra-resources integration test to MJAVADOC-126
        Vincent Siveton added a comment -

        Fixed in r662003, snapshot deployed. Thanks!

        Julien Eluard added a comment -

        This feature seems to work only when the parent of project configured references resourcesArtifact artifact as module.

        In provided sample if I remove the modules section of root pom.xml, then run mvn clean javadoc:javadoc under test folder files are not correctly copied.
        Is this the intended behavior?


          People

          • Assignee:
            Vincent Siveton
            Reporter:
            Julien S
          • Votes:
            0 Vote for this issue
            Watchers:
            0 Start watching this issue

            Dates

            • Created:
              Updated:
              Resolved: