Maven Install Plugin
  1. Maven Install Plugin
  2. MINSTALL-37

Add support to force install:install to use a specific version

    Details

    • Type: New Feature New Feature
    • Status: Closed Closed
    • Priority: Major Major
    • Resolution: Won't Fix
    • Affects Version/s: 2.2
    • Fix Version/s: None
    • Component/s: None
    • Labels:
      None
    • Number of attachments :
      1

      Description

      Allow the install:install goal to force the version of artifacts (including attached).

        Issue Links

          Activity

          Jason Dillon added a comment -

          The attached patch adds support for an optional forceVersion parameter which is a String. When non-null, this will cause new artifacts to be created with their versions set to the value of forceVersion.

          This does not affect current usage of install:install, with out forceVersion set the goal behaves exactly as it did before.

          This feature is intended to support testing and some other edge cases, but not intended for mainstream usage.

          brianfox brianfox added a comment -

          this patch looks ok, but the classifier should be passed through to the factory instead of null.

          Stéphane Nicoll added a comment -

          Brian, I guess MINSTALL-30 is rather a duplicate of this one. WDYT?

          brianfox brianfox added a comment -

          Similar, but not exactly a duplicate.

          brianfox brianfox added a comment -

          The general consensus seems to be that this should not be added.

          Dennis Lundberg added a comment -

          Remove "Fix Version" as the issue was not fixed.


            People

            • Assignee:
              brianfox brianfox
              Reporter:
              Jason Dillon
            • Votes:
              0 Vote for this issue
              Watchers:
              0 Start watching this issue

              Dates

              • Created:
                Updated:
                Resolved: